summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zachary.medico@sony.com>2019-06-21 19:18:00 -0700
committerZac Medico <zmedico@gentoo.org>2019-06-24 18:34:00 -0700
commit92ba502a5a7af071acffa095f1469f8e1f828728 (patch)
treea39de8ecb36e2a14601385b6060865137fc3e134 /dev-python
parentdev-python/cfn-python-lint: New package (diff)
downloadgentoo-92ba502a5a7af071acffa095f1469f8e1f828728.tar.gz
gentoo-92ba502a5a7af071acffa095f1469f8e1f828728.tar.bz2
gentoo-92ba502a5a7af071acffa095f1469f8e1f828728.zip
dev-python/moto: Bump to version 1.3.8
Bug: https://bugs.gentoo.org/688034 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-1.3.8.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index de5f905db667..d5e90c894b68 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -1,2 +1,3 @@
DIST moto-0.4.30.tar.gz 614008 BLAKE2B 2868ab25414e488299cb521ce814239698466d69e806245fd86ceb9d5835d08fa530f2da0a5a16f595a88b3c0e421cc264f361bc68d31841726896826240fbab SHA512 ece27979911f46adbb0aec9aa3755b13c09ced00b24ea136ab9c8a8a992550e9c38dac15d8b0c71822953f070761083253ee5fb5cbe44a4b108d140ab4407699
DIST moto-1.0.1.tar.gz 731617 BLAKE2B 6f20c07c0635a8c10f8f70530aeaac5ed7c2136d4fc87ff57774a95f4d2e1ea8cf1100b9f0871b29138cec9059de5746a9c01104d856f8248edbb648cc4a78e0 SHA512 3171ea3e8f9d267960a7b82caf7e42b86fceba5a80e96d35b849e4e72b7fc6aed94090161219a520f9c1b4050f7de12e0f6c0d560ab1f90ca43fc0387b62d377
+DIST moto-1.3.8.tar.gz 1571716 BLAKE2B 8e79808d8488bcf8c15e8b5a55e93392ceb5f642f1f52c0af441cecb7adfe23a718f6d283e473e5dab82ddd21bcbed36ecb52b444cbd933405d13c8818e4f74d SHA512 901556249a2a28885b7f77e9f2c209b06391efcea66b78ce3c16edec14bcd03b251c37ef5d800d8f7a35180d59ce7568a68bcebf18e25b092eb5de801db6c587
diff --git a/dev-python/moto/moto-1.3.8.ebuild b/dev-python/moto/moto-1.3.8.ebuild
new file mode 100644
index 000000000000..3849836febed
--- /dev/null
+++ b/dev-python/moto/moto-1.3.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/aws-xray-sdk-python[${PYTHON_USEDEP}]
+ dev-python/backports-tempfile[${PYTHON_USEDEP}]
+ dev-python/cfn-python-lint[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ dev-python/dicttoxml[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.8[${PYTHON_USEDEP}]
+ dev-python/jsondiff[${PYTHON_USEDEP}]
+ >=dev-python/boto-2.36.0[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.6.16[${PYTHON_USEDEP}]
+ >=dev-python/botocore-1.12.13[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Disable tests that fail with network-sandbox.
+ sed -e 's|^\(def \)\(test_context_manager()\)|\1_\2|' \
+ -e 's|^\(def \)\(test_decorator_start_and_stop()\)|\1_\2|' \
+ -i tests/test_core/test_decorator_calls.py || die
+
+ # Disable tests that fail with userpriv.
+ sed -e 's|^\(def \)\(test_invoke_function_from_sns()\)|\1_\2|' \
+ -e 's|^\(def \)\(test_invoke_requestresponse_function()\)|\1_\2|' \
+ -i tests/test_awslambda/test_lambda.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH=${BUILDDIR}/lib \
+ nosetests -sv ./tests || die
+}