summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-25 20:38:49 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-25 20:38:49 +0200
commit92d805695a61a79444093f243a424d4137f94c23 (patch)
tree51ecf61e82ea1424df6e1249592881059a456655 /dev-python
parentsci-visualization/qtiplot: Use optfeature (diff)
downloadgentoo-92d805695a61a79444093f243a424d4137f94c23.tar.gz
gentoo-92d805695a61a79444093f243a424d4137f94c23.tar.bz2
gentoo-92d805695a61a79444093f243a424d4137f94c23.zip
dev-python/rpy: Drop old
obsolets Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=489138 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=556394 Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rpy/Manifest2
-rw-r--r--dev-python/rpy/rpy-2.5.4.ebuild50
-rw-r--r--dev-python/rpy/rpy-2.6.1.ebuild53
3 files changed, 0 insertions, 105 deletions
diff --git a/dev-python/rpy/Manifest b/dev-python/rpy/Manifest
index a03dd7c26fc8..90514ef46bf5 100644
--- a/dev-python/rpy/Manifest
+++ b/dev-python/rpy/Manifest
@@ -1,3 +1 @@
-DIST rpy2-2.5.4.tar.gz 164830 SHA256 d521ecdd05cd0c31ab017cb63e9f63c29b524e46ec9063a920f640b5875f8a90 SHA512 e40ae81be19acf5008eed088c10fef3824cc712c0175414c1899bf45b24c35e2ef7d8808fae75d156064e82d1cd5939c50d5291c190030ae2050c6dffa9a36db WHIRLPOOL 2769adccaa6a634b964d4712e4bcc4d4161f8aef17d38a235bf5a3646fd166a01749fcc1852954996a00b695617597617f0dfb43f73744948a55f2eba07d9ba2
-DIST rpy2-2.6.1.tar.gz 171635 SHA256 39f15d7f5d51646a6cbf9d5cd1c817d2880301dbb95141947f93361685453e28 SHA512 14c6c47d6ace40ac26bf89d3efdbf5c5a68f74096fec74897877be312d3ffb03c30f4ca13ed1531ccf094ac33672fa550264fe980788bc4eca12d02089475f63 WHIRLPOOL dda6a0a2abe33f8d7e3a489c6bbaa03335a47d5fa474409883773a52be315f0920347a38f76f94e9e16c680e08cd8e7a18d27a6a2ffd4af35a779a305836bdd5
DIST rpy2-2.6.2.tar.gz 171655 SHA256 2e28886b2a6a138cfc057f9b7cddade253e61c9abb43f0eae20dace58b6dfced SHA512 7a060ccc26a03dc93d75edb85d92f1ab31af96ba140932ff8e699cd5855e6078b1e0ffceed135d32deb6c8f273ebcc8b02be38e9b8fc66778cc2adab5745f542 WHIRLPOOL 26d9a9c13e4efa22a232507cfff0b13d650e0528f635dfa9fe464cde50462d2d94a668d1566b537bafaa5462eb66e96005296c6295308b1e3d1c5639da2879b6
diff --git a/dev-python/rpy/rpy-2.5.4.ebuild b/dev-python/rpy/rpy-2.5.4.ebuild
deleted file mode 100644
index fd4fe9abfcd3..000000000000
--- a/dev-python/rpy/rpy-2.5.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1 flag-o-matic
-
-MYSLOT=2
-MY_PN=${PN}${MYSLOT}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python interface to the R Programming Language"
-HOMEPAGE="http://rpy.sourceforge.net/ https://pypi.python.org/pypi/rpy2"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="AGPL-3 GPL-2 LGPL-2.1 MPL-1.1"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-lang/R-3
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.13.1[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( $(python_gen_cond_dep 'dev-python/singledispatch[${PYTHON_USEDEP}]' python2_7 python3_3) )"
-
-# ggplot2 is an optional test dep but not in portage
-S="${WORKDIR}/${MY_P}"
-
-# Tarball absent of doc files in doc folder
-# https://bitbucket.org/lgautier/rpy2/issue/229/
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- ${PYTHON} -m 'rpy2.tests' || die
-}
diff --git a/dev-python/rpy/rpy-2.6.1.ebuild b/dev-python/rpy/rpy-2.6.1.ebuild
deleted file mode 100644
index de5f7205b05f..000000000000
--- a/dev-python/rpy/rpy-2.6.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1 flag-o-matic
-
-MYSLOT=2
-MY_PN=${PN}${MYSLOT}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python interface to the R Programming Language"
-HOMEPAGE="http://rpy.sourceforge.net/ https://pypi.python.org/pypi/rpy2"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="AGPL-3 GPL-2 LGPL-2.1 MPL-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-lang/R-3
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.13.1[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- virtual/python-singledispatch[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( $(python_gen_cond_dep 'dev-python/singledispatch[${PYTHON_USEDEP}]' python2_7 python3_3) )"
-
-# ggplot2 is an optional test dep but not in portage
-S="${WORKDIR}/${MY_P}"
-
-# Tarball absent of doc files in doc folder
-# https://bitbucket.org/rpy2/rpy2/issues/229
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- ${PYTHON} -m 'rpy2.tests' || die
-}