summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 16:36:34 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 17:14:38 +0200
commit94f228e54247c299b8ba4b0b6f9a50ed54c961f2 (patch)
treee3721ebb37e65c8629561a30f847689aefd2e7ed /dev-python
parentdev-python/mysqlclient: Clean old versions up (diff)
downloadgentoo-94f228e54247c299b8ba4b0b6f9a50ed54c961f2.tar.gz
gentoo-94f228e54247c299b8ba4b0b6f9a50ed54c961f2.tar.bz2
gentoo-94f228e54247c299b8ba4b0b6f9a50ed54c961f2.zip
dev-python/routes: Clean old versions up
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/routes/Manifest3
-rw-r--r--dev-python/routes/files/routes-2.0-tests-py3.patch40
-rw-r--r--dev-python/routes/routes-2.1-r1.ebuild72
-rw-r--r--dev-python/routes/routes-2.2.ebuild55
-rw-r--r--dev-python/routes/routes-2.3.1.ebuild55
5 files changed, 0 insertions, 225 deletions
diff --git a/dev-python/routes/Manifest b/dev-python/routes/Manifest
index 90deb7cb8b9a..d7f0003760c9 100644
--- a/dev-python/routes/Manifest
+++ b/dev-python/routes/Manifest
@@ -1,4 +1 @@
-DIST Routes-2.1.tar.gz 179737 SHA256 ebf4126e244cf11414653b5ba5f27ed4abfad38b906a01e5d4c93d3ce5568ea3 SHA512 6dcea3e20d9883e29d6aea5949eef3b265094f46084234a15530c266930163918c6eb2ad00bb49cd9cbf947a0019c2d91a5455f997bc7a7e5b8c662837a728c2 WHIRLPOOL fbdb8e1a84aa2b1b8bf011aa68a31364f0fd48cabcaaf413274679f34e514283fbd8aac9497444b24f69f7d72393f38aeab5eeeb96659e3aae009ed2eebc4fbf
-DIST Routes-2.2.tar.gz 180011 SHA256 9fa78373d63e36c3d8af6e33cfcad743f70c012c7ad6f2c3bf89ad973b9ab514 SHA512 ddd88c412fce902aa75be46dd564bea7fed630116d50c0f08db6813de26bbb7af5adf7366dd3664a0fc10e369ed5089f6cc9ac91cc236e1b45c828fe2deee2e2 WHIRLPOOL 9fe75ce3826e64ff46db35fdb47c655f86709fdbfb64ad317b2f672e761a717bc2b4c2fd18f1675b36922d65300cd2f7acec87cb08ceeb50cb85fb099c15209f
-DIST Routes-2.3.1.tar.gz 181694 SHA256 98c380b5dc1190b873463be07383728ada18f66d2615531963004b9d6fb90351 SHA512 125bcee31883e55ac2c01896e52890c1eace238728e9f340b9dede8257e66b1002cf48a633b9b0c3421291287559890c3233665cd49b1edb4ed80a99f003da8d WHIRLPOOL 2e8f931c0ac85bc7e0f46dea7b0e38798f8d37005266e40986450d2b3d71c2621150ec8aead05691244622f24b097932e5eb476089f262b8a1b7c19db1333a33
DIST Routes-2.4.1.tar.gz 182403 SHA256 26ee43340fca5a32769ffe0c58edcb396ccce6bc1dfa689ddf844d50877355fd SHA512 b0566f10ca83af0459e9c59fa2217bdc5ebf349d944396bcb21ffa731ad189c642e409381979cb5da3153630c24f20aa974a99711f16aca9f91413976af2bb04 WHIRLPOOL ebbc6f66befc2260c68833cc574eb76a6a1360cbcc45f3a27c9ebe718c21d37c474644ec1d5f6019213dcd018e671fb3d0321227eaa351743ad71afced12354d
diff --git a/dev-python/routes/files/routes-2.0-tests-py3.patch b/dev-python/routes/files/routes-2.0-tests-py3.patch
deleted file mode 100644
index ec21799ba14f..000000000000
--- a/dev-python/routes/files/routes-2.0-tests-py3.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Fix tests to work with random hash dicts.
-
---- a/tests/test_functional/test_generation.py
-+++ b/tests/test_functional/test_generation.py
-@@ -205,13 +205,14 @@ class TestGeneration(unittest.TestCase):
- requirements={'month':'\d{1,2}','day':'\d{1,2}'})
- m.connect('viewpost/:id', controller='post', action='view')
- m.connect(':controller/:action/:id')
--
-- eq_('/blog/view?year=2004&month=blah', m.generate(controller='blog', action='view', year=2004, month='blah'))
-+
-+ url = m.generate(controller='blog', action='view', year=2004, month='blah')
-+ assert url == '/blog/view?year=2004&month=blah' or url == '/blog/view?month=blah&year=2004'
- eq_('/archive/2004/11', m.generate(controller='blog', action='view', year=2004, month=11))
- eq_('/archive/2004/11', m.generate(controller='blog', action='view', year=2004, month='11'))
- eq_('/archive/2004', m.generate(controller='blog', action='view', year=2004))
- eq_('/viewpost/3', m.generate(controller='post', action='view', id=3))
--
-+
- def test_multiroute_with_splits(self):
- m = Mapper(explicit=False)
- m.minimization = True
-@@ -219,13 +220,14 @@ class TestGeneration(unittest.TestCase):
- requirements={'month':'\d{1,2}','day':'\d{1,2}'})
- m.connect('viewpost/:(id)', controller='post', action='view')
- m.connect(':(controller)/:(action)/:(id)')
--
-- eq_('/blog/view?year=2004&month=blah', m.generate(controller='blog', action='view', year=2004, month='blah'))
-+
-+ url = m.generate(controller='blog', action='view', year=2004, month='blah')
-+ assert url == '/blog/view?year=2004&month=blah' or url == '/blog/view?month=blah&year=2004'
- eq_('/archive/2004/11', m.generate(controller='blog', action='view', year=2004, month=11))
- eq_('/archive/2004/11', m.generate(controller='blog', action='view', year=2004, month='11'))
- eq_('/archive/2004', m.generate(controller='blog', action='view', year=2004))
- eq_('/viewpost/3', m.generate(controller='post', action='view', id=3))
--
-+
- def test_big_multiroute(self):
- m = Mapper(explicit=False)
- m.minimization = True
diff --git a/dev-python/routes/routes-2.1-r1.ebuild b/dev-python/routes/routes-2.1-r1.ebuild
deleted file mode 100644
index f860d3d54fbe..000000000000
--- a/dev-python/routes/routes-2.1-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1
-
-MY_PN="Routes"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Python re-implementation of Rails routes system, mapping URL's to Controllers/Actions"
-HOMEPAGE="http://routes.groovie.org https://pypi.python.org/pypi/Routes"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/webtest[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- )"
-# It appears there's an epidemic of missing testsuites coming out of github. Restrict for now
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-# Comment out patch for tests for now
-#PATCHES=( "${FILESDIR}"/${PN}-2.0-tests-py3.patch )
-
-# https://github.com/bbangert/routes/issues/42 presents a patch
-# for the faulty docbuild converted to sed stmnts
-python_prepare_all() {
- use test && DISTUTILS_IN_SOURCE_BUILD=1
- # The default theme in sphinx switched to classic from shpinx-1.3.1
- if has_version ">=dev-python/sphinx-1.3.1"; then
- sed -e "s:html_theme_options = {:html_theme = 'classic'\n&:" \
- -i docs/conf.py || die
- else
- sed -e "s:html_theme_options = {:html_theme = 'default'\n&:" \
- -i docs/conf.py || die
- fi
- sed -e "s:changes:changes\n todo:" \
- -i docs/index.rst || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- cp -r tests "${BUILD_DIR}" || die
- if [[ ${EPYTHON} == python3* ]]; then
- 2to3 -w --no-diffs "${BUILD_DIR}"/tests || die
- fi
-
- nosetests -w "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/routes/routes-2.2.ebuild b/dev-python/routes/routes-2.2.ebuild
deleted file mode 100644
index 5c1017751def..000000000000
--- a/dev-python/routes/routes-2.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-MY_PN="Routes"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Python re-implementation of Rails routes system, mapping URL's to Controllers/Actions"
-HOMEPAGE="http://routes.groovie.org https://pypi.python.org/pypi/Routes"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-RDEPEND=">=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-# The testsuite appears to be held back by the author
-
-S="${WORKDIR}/${MY_P}"
-
-# https://github.com/bbangert/routes/issues/42 presents a patch
-# for the faulty docbuild converted to sed stmnts
-python_prepare_all() {
- # The default theme in sphinx switched to classic from shpinx-1.3.1
- if has_version ">=dev-python/sphinx-1.3.1"; then
- sed -e "s:html_theme_options = {:html_theme = 'classic'\n&:" \
- -i docs/conf.py || die
- else
- sed -e "s:html_theme_options = {:html_theme = 'default'\n&:" \
- -i docs/conf.py || die
- fi
- sed -e "s:changes:changes\n todo:" \
- -i docs/index.rst || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/routes/routes-2.3.1.ebuild b/dev-python/routes/routes-2.3.1.ebuild
deleted file mode 100644
index b6be9afdede4..000000000000
--- a/dev-python/routes/routes-2.3.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-MY_PN="Routes"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A re-implementation of Rails routes system, mapping URLs to Controllers/Actions"
-HOMEPAGE="http://routes.groovie.org https://pypi.python.org/pypi/Routes"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-RDEPEND=">=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-# The testsuite appears to be held back by the author
-
-S="${WORKDIR}/${MY_P}"
-
-# https://github.com/bbangert/routes/issues/42 presents a patch
-# for the faulty docbuild converted to sed stmnts
-python_prepare_all() {
- # The default theme in sphinx switched to classic from shpinx-1.3.1
- if has_version ">=dev-python/sphinx-1.3.1"; then
- sed -e "s:html_theme_options = {:html_theme = 'classic'\n&:" \
- -i docs/conf.py || die
- else
- sed -e "s:html_theme_options = {:html_theme = 'default'\n&:" \
- -i docs/conf.py || die
- fi
- sed -e "s:changes:changes\n todo:" \
- -i docs/index.rst || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}