summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-03-18 19:47:17 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-03-18 19:47:17 -0400
commit95ea4e83efda3fb594936d53a980f2c84031151e (patch)
treef180ee5035e08d6ae1eac5b49dcdebaf2def3c22 /dev-python
parentdev-python/pylint: fix docs build (diff)
downloadgentoo-95ea4e83efda3fb594936d53a980f2c84031151e.tar.gz
gentoo-95ea4e83efda3fb594936d53a980f2c84031151e.tar.bz2
gentoo-95ea4e83efda3fb594936d53a980f2c84031151e.zip
dev-python/pylint: remove pytest-runner dependency
It's useless Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/files/pylint-2.3.1-no-pytest-runner.patch12
-rw-r--r--dev-python/pylint/pylint-2.3.1.ebuild2
2 files changed, 13 insertions, 1 deletions
diff --git a/dev-python/pylint/files/pylint-2.3.1-no-pytest-runner.patch b/dev-python/pylint/files/pylint-2.3.1-no-pytest-runner.patch
new file mode 100644
index 000000000000..4caf59bb30ec
--- /dev/null
+++ b/dev-python/pylint/files/pylint-2.3.1-no-pytest-runner.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index a7b5e413..841a1c0d 100644
+--- a/setup.py
++++ b/setup.py
+@@ -169,7 +169,6 @@ def install(**kwargs):
+ extras_require=extras_require,
+ test_suite='test',
+ python_requires='>=3.4.*',
+- setup_requires=['pytest-runner'],
+ tests_require=['pytest'],
+ **kwargs)
+
diff --git a/dev-python/pylint/pylint-2.3.1.ebuild b/dev-python/pylint/pylint-2.3.1.ebuild
index a9f24be3a26e..7e1e963e3a5d 100644
--- a/dev-python/pylint/pylint-2.3.1.ebuild
+++ b/dev-python/pylint/pylint-2.3.1.ebuild
@@ -24,7 +24,6 @@ RDEPEND="
>=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
dev-python/mccabe[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( ${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
@@ -33,6 +32,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
PATCHES=(
"${FILESDIR}/${PN}-2.3.1-sphinx-theme.patch"
+ "${FILESDIR}/${PN}-2.3.1-no-pytest-runner.patch"
)
python_compile_all() {