summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-01-10 12:50:14 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-10 13:03:58 +0200
commit9702d29ef0c7e008595e8050b7d9e41f6572477d (patch)
treef15027fb170a19223a64ab77cd8b399a7e62dcba /dev-python
parentsci-libs/scikit-image: drop 0.19.3 (diff)
downloadgentoo-9702d29ef0c7e008595e8050b7d9e41f6572477d.tar.gz
gentoo-9702d29ef0c7e008595e8050b7d9e41f6572477d.tar.bz2
gentoo-9702d29ef0c7e008595e8050b7d9e41f6572477d.zip
dev-python/imageio: drop 2.22.4, 2.23.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-2.22.4.ebuild82
-rw-r--r--dev-python/imageio/imageio-2.23.0.ebuild82
3 files changed, 0 insertions, 165 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index 97993cfe366c..ec085a048981 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1,4 +1,3 @@
-DIST imageio-2.22.4.gh.tar.gz 395090 BLAKE2B 8980516e26c3a8d128937046582b796264616922f10c5a347ec9b718c773666fe431b2426abbf1de2c99a27cfdc1d7747727c23b2dd665ae88e405746966896e SHA512 38339e7da4ae238cf91aae4ec500899edf7547e80029941550ea73c6b0ba926eac21f4a234833ce52078426c660409558935b72775f3131a390f913fefdb0df1
DIST imageio-2.23.0.gh.tar.gz 395916 BLAKE2B 2ca40f70dfc3f79084933a22ab2f841ecee0c5f0768dd73ea264a366853cc582111e677fb1521f74f3b2ff516f0ab51de013e8e013dafbe5cf0386faf21b75f5 SHA512 dcdea9fb245495b0882630f18bd5503c4e36fa3f3b50dc58712a8a246424855cd0f280e026889eb8a6a4f7d833792f87d373f645e59ff39fb81514ada79f4248
DIST imageio-2.24.0.gh.tar.gz 401266 BLAKE2B a5b247304edc53288d1589b2ff9e6efcd221f56581624bf0df6c18171841aebf334e1394110470d18c7fc33a4f5b27b52c7e76e51d2129fddefbb73932e02cb5 SHA512 ec86136701945deeb79db64a8e0787234f9d4b62e30be22a8d6f53d4daa2abaa6d2b1a95eaf7f6f97559f99427734cd4b85145feed5fbb53356d902cc391a998
DIST imageio-chelsea.png 221294 BLAKE2B 58537d7a1678fa5be4cc899e5bacd925bfc180eb4ae691330a53749a49ff544e979609b529ed27e5c1fc9efe4bc050ca1ce49b777f4016fb1d66affd926ef9d3 SHA512 48470cdb843eed4dfa6673811c09c5aac9869ee23dd36be0c6b653d9f108d61d21b148c2a4435aaa6604887ba030e5bbc5e35d378da876366445dfc2d0ba4e27
diff --git a/dev-python/imageio/imageio-2.22.4.ebuild b/dev-python/imageio/imageio-2.22.4.ebuild
deleted file mode 100644
index bd86d3699c16..000000000000
--- a/dev-python/imageio/imageio-2.22.4.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-BIN_COMMIT=224074bca448815e421a59266864c23041531a42
-DESCRIPTION="Python library for reading and writing image data"
-HOMEPAGE="
- https://imageio.readthedocs.io/en/stable/
- https://github.com/imageio/imageio/
- https://pypi.org/project/imageio/
-"
-SRC_URI="
- https://github.com/imageio/imageio/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
- test? (
- https://github.com/imageio/imageio-binaries/raw/${BIN_COMMIT}/images/chelsea.png
- -> ${PN}-chelsea.png
- https://github.com/imageio/imageio-binaries/raw/${BIN_COMMIT}/images/cockatoo.mp4
- -> ${PN}-cockatoo.mp4
- )
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# over 50% of tests rely on Internet
-PROPERTIES="test_network"
-RESTRICT="test"
-
-RDEPEND="
- >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
- media-libs/freeimage
-"
-# requests for fsspec[github]
-BDEPEND="
- test? (
- dev-python/fsspec[${PYTHON_USEDEP}]
- dev-python/imageio-ffmpeg[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/tifffile[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- # block silently downloading vulnerable libraries from the Internet
- "${FILESDIR}"/imageio-2.22.0-block-download.patch
- )
-
- if use test; then
- mkdir -p "${HOME}"/.imageio/images || die
- local i
- for i in chelsea.png cockatoo.mp4; do
- cp "${DISTDIR}/${PN}-${i}" "${HOME}/.imageio/images/${i}" || die
- done
- fi
-
- distutils-r1_src_prepare
-}
-
-EPYTEST_DESELECT=(
- # Fails because of system installed freeimage
- tests/test_core.py::test_findlib2
- # Tries to download ffmpeg binary ?!
- tests/test_ffmpeg.py::test_get_exe_installed
- # blocked by our patch
- tests/test_core.py::test_fetching
- tests/test_core.py::test_request
- # known broken
- # https://github.com/imageio/imageio/issues/890
- tests/test_freeimage.py::test_exr_write
-)
diff --git a/dev-python/imageio/imageio-2.23.0.ebuild b/dev-python/imageio/imageio-2.23.0.ebuild
deleted file mode 100644
index bd86d3699c16..000000000000
--- a/dev-python/imageio/imageio-2.23.0.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-BIN_COMMIT=224074bca448815e421a59266864c23041531a42
-DESCRIPTION="Python library for reading and writing image data"
-HOMEPAGE="
- https://imageio.readthedocs.io/en/stable/
- https://github.com/imageio/imageio/
- https://pypi.org/project/imageio/
-"
-SRC_URI="
- https://github.com/imageio/imageio/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
- test? (
- https://github.com/imageio/imageio-binaries/raw/${BIN_COMMIT}/images/chelsea.png
- -> ${PN}-chelsea.png
- https://github.com/imageio/imageio-binaries/raw/${BIN_COMMIT}/images/cockatoo.mp4
- -> ${PN}-cockatoo.mp4
- )
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# over 50% of tests rely on Internet
-PROPERTIES="test_network"
-RESTRICT="test"
-
-RDEPEND="
- >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
- media-libs/freeimage
-"
-# requests for fsspec[github]
-BDEPEND="
- test? (
- dev-python/fsspec[${PYTHON_USEDEP}]
- dev-python/imageio-ffmpeg[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/tifffile[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- # block silently downloading vulnerable libraries from the Internet
- "${FILESDIR}"/imageio-2.22.0-block-download.patch
- )
-
- if use test; then
- mkdir -p "${HOME}"/.imageio/images || die
- local i
- for i in chelsea.png cockatoo.mp4; do
- cp "${DISTDIR}/${PN}-${i}" "${HOME}/.imageio/images/${i}" || die
- done
- fi
-
- distutils-r1_src_prepare
-}
-
-EPYTEST_DESELECT=(
- # Fails because of system installed freeimage
- tests/test_core.py::test_findlib2
- # Tries to download ffmpeg binary ?!
- tests/test_ffmpeg.py::test_get_exe_installed
- # blocked by our patch
- tests/test_core.py::test_fetching
- tests/test_core.py::test_request
- # known broken
- # https://github.com/imageio/imageio/issues/890
- tests/test_freeimage.py::test_exr_write
-)