summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-11 16:22:48 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-11 16:49:28 +0200
commit9b70f573cdc659e9112e677edb37320dbbea7f86 (patch)
treefb67cc26624297a3667d105f740ec284e026608f /dev-python
parentprofiles: cleanup (diff)
downloadgentoo-9b70f573cdc659e9112e677edb37320dbbea7f86.tar.gz
gentoo-9b70f573cdc659e9112e677edb37320dbbea7f86.tar.bz2
gentoo-9b70f573cdc659e9112e677edb37320dbbea7f86.zip
dev-python/fastjsonschema: New package, dep of nbformat
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fastjsonschema/Manifest1
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.14.5.ebuild26
-rw-r--r--dev-python/fastjsonschema/metadata.xml7
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
new file mode 100644
index 000000000000..8835172bcb41
--- /dev/null
+++ b/dev-python/fastjsonschema/Manifest
@@ -0,0 +1 @@
+DIST python-fastjsonschema-2.14.5.tar.gz 33488 BLAKE2B 4604ebd46851c8fe856909fa3943e053ac7359a9f360c189add2a46780fe045ca1952033174d008db7696bfc861a504c3aaa7389c33a2edbccd10cb14de8a097 SHA512 255db86d1d62845e512ca5669f3200360847d974710050ac53fe88536d6d9f943ccf41a8414702dad70fa1a38defe9859f2b608e13a54af11199c90d63cdf1d0
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.14.5.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.14.5.ebuild
new file mode 100644
index 000000000000..cb687ee9c337
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.14.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="https://github.com/horejsek/python-fastjsonschema/"
+SRC_URI="
+ https://github.com/horejsek/python-fastjsonschema/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm -r tests/benchmarks || die
+}
diff --git a/dev-python/fastjsonschema/metadata.xml b/dev-python/fastjsonschema/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/fastjsonschema/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>