summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2019-03-24 17:53:38 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-26 17:45:25 +0100
commit9c37fa91155a0ed35c901e627fc87038386ca874 (patch)
tree17ec4a1f16551b1498851d25bd94326ec0aa7269 /dev-python
parentnet-im/spectrum2: drop old version. (diff)
downloadgentoo-9c37fa91155a0ed35c901e627fc87038386ca874.tar.gz
gentoo-9c37fa91155a0ed35c901e627fc87038386ca874.tar.bz2
gentoo-9c37fa91155a0ed35c901e627fc87038386ca874.zip
dev-python/importlib_resources: new package.
Backport of Python 3.7's standard library importlib.resources module for Python 2.7, and 3.4 through 3.6. Users of Python 3.7 and beyond are encouraged to use the standard library module, and in fact for these versions, importlib_resources just shadows that module. Gentoo specific, I removed Python 3.4 from PYTHON_COMPAT, because that version is masked and will be removed soon (see https://github.com/gentoo/gentoo/pull/11482#issuecomment-476083100). Signed-off-by: Ralph Seichter <gentoo@seichter.de> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://bugs.gentoo.org/681670 Closes: https://github.com/gentoo/gentoo/pull/11482 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/importlib_resources/Manifest1
-rw-r--r--dev-python/importlib_resources/importlib_resources-1.0.2.ebuild27
-rw-r--r--dev-python/importlib_resources/metadata.xml22
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/importlib_resources/Manifest b/dev-python/importlib_resources/Manifest
new file mode 100644
index 000000000000..6b5b888e590f
--- /dev/null
+++ b/dev-python/importlib_resources/Manifest
@@ -0,0 +1 @@
+DIST importlib_resources-1.0.2.tar.gz 23605 BLAKE2B 813f913a779115575f3cab6f5be8f9e7ea706a6f0e47bc0bb29439901515b435c33975f6b1fd96d74140e488b0bd98aca3331e0d69940153b348891fd5f4f400 SHA512 3b7b254abdf2cb8ee0abf1608123c49de05d1eada081567a0e083d1f496f37643b81e771490b414dcf56672a7e7ea9aa6dd6b77ea8206d3a97e81ad69da7e927
diff --git a/dev-python/importlib_resources/importlib_resources-1.0.2.ebuild b/dev-python/importlib_resources/importlib_resources-1.0.2.ebuild
new file mode 100644
index 000000000000..830ec759d0b0
--- /dev/null
+++ b/dev-python/importlib_resources/importlib_resources-1.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="https://importlib-resources.readthedocs.io/en/latest/"
+SRC_URI="https://gitlab.com/python-devs/${PN}/-/archive/${PV}/${P}.tar.gz"
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/importlib_resources/metadata.xml b/dev-python/importlib_resources/metadata.xml
new file mode 100644
index 000000000000..af87c20668a9
--- /dev/null
+++ b/dev-python/importlib_resources/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@seichter.de</email>
+ <name>Ralph Seichter</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Backport of Python 3.7’s standard library importlib.resources
+ module for Python 2.7, and 3.4 through 3.6. Users of Python
+ 3.7 and beyond are encouraged to use the standard library
+ module, and in fact for these versions, importlib_resources
+ just shadows that module.
+ </longdescription>
+ <upstream>
+ <remote-id type="gitlab">python-devs/importlib_resources</remote-id>
+ </upstream>
+</pkgmetadata>