summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-04-04 20:49:56 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-04-04 20:49:56 +0200
commit9dbf9ce78d85a131c1574dc2e05b742c8cf51f69 (patch)
treedff24aa09dd17b61709737f42b32ea3c719c3eb7 /dev-python
parentdev-python/pylint: Restrict dep on astroid (diff)
downloadgentoo-9dbf9ce78d85a131c1574dc2e05b742c8cf51f69.tar.gz
gentoo-9dbf9ce78d85a131c1574dc2e05b742c8cf51f69.tar.bz2
gentoo-9dbf9ce78d85a131c1574dc2e05b742c8cf51f69.zip
dev-python/pylint: Remove broken
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/pylint-1.5.5.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/pylint/pylint-1.5.5.ebuild b/dev-python/pylint/pylint-1.5.5.ebuild
deleted file mode 100644
index 355d5cfb4634..000000000000
--- a/dev-python/pylint/pylint-1.5.5.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="
- http://www.logilab.org/project/pylint
- https://pypi.python.org/pypi/pylint
- https://github.com/pycqa/pylint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-RDEPEND="
- >=dev-python/astroid-1.4.1[${PYTHON_USEDEP}]
- <dev-python/astroid-1.5.0[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND} )"
-
-RESTRICT="test" # multiple failures
-
-# Usual. Requ'd for impl specific failures in test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- # selection of straight html triggers a trivial annoying bug, we skirt it
- use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml
-}
-
-python_test() {
- ${PYTHON} \
- -m unittest discover \
- -s pylint/test/ -p "*test_*".py \
- --verbose || die
-}
-
-python_install_all() {
- doman man/{pylint,pyreverse}.1
- use examples && local EXAMPLES=( examples/. )
- use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- # Optional dependency on "tk" USE flag would break support for Jython.
- optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." dev-lang/python[tk]
-}