summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-03 20:53:23 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-03 21:55:48 +0200
commita75f93df34b92bcfb841445aa7fe92f7d8a5e56a (patch)
tree4471963f9b5457d421107a9357906b1a168d7471 /dev-python
parentapp-arch/stormlib: Bump to 9.24 (diff)
downloadgentoo-a75f93df34b92bcfb841445aa7fe92f7d8a5e56a.tar.gz
gentoo-a75f93df34b92bcfb841445aa7fe92f7d8a5e56a.tar.bz2
gentoo-a75f93df34b92bcfb841445aa7fe92f7d8a5e56a.zip
dev-python/trimesh: Bump to 3.15.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-3.15.3.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 7a9a59718794..6a87f7eef3e1 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,2 +1,3 @@
DIST trimesh-3.14.1.gh.tar.gz 11961899 BLAKE2B eab37c94da03cfdefa2f4bff78a1a1cdd2a4c5d3d5da7ef5f462de331c7c2dbaaabbc53a0033ca95a3b4d9d61e072af2f2b689d291e32a89531ca2b5e9d8f8e2 SHA512 e8c43275552d2ddf2e6c1d7582c67f34d7bdaddd5df2cfac9a3758eac12a7fc8bc41748465317eb4e983d7d2d9d51209ab85bfa781022227c0be57618991e9b4
DIST trimesh-3.15.2.gh.tar.gz 11956076 BLAKE2B 4ec701056efd29eb24eaf4edc82d07af4b8e02713697f658ea86eaef6f94916d51c3b21873b3da720705f281054ab5564f4331dc3ee9614d37774bdc03dd1c77 SHA512 9ae3917f2485f5eba089fd04029187be356bbb032d8afa57801a5c19a897550a34bd6734848a47c937b42745fd4563a5a05352928f5e31a7146a3b002d6c765d
+DIST trimesh-3.15.3.gh.tar.gz 11955970 BLAKE2B 050a1330ff0d3d308f3f54bee9080907b839e8cfcc9bdc831d3c5033225a9868aefe2ceb39313949288c779a1af577911a7e43fe2745f50c4983c178dcf02742 SHA512 e01192496af519be7f4d04b6268f82227a0d00c2feebf294572cdd6cce151d10d271cb8b8558c48200338d2f6ea4137fe75d92d115ea8b42f0117ad135566d05
diff --git a/dev-python/trimesh/trimesh-3.15.3.ebuild b/dev-python/trimesh/trimesh-3.15.3.ebuild
new file mode 100644
index 000000000000..11e1a73dfac5
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.15.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimsh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs)"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}