summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2015-09-03 09:49:37 -0700
committerBrian Dolbec <dolsen@gentoo.org>2015-09-03 09:53:08 -0700
commita76e5418e340a9012bcb87b75d6c2a5f355e03af (patch)
tree973d7ce79db913391e10f65206cd91010938885d /dev-python
parentwww-servers/tomcat: version bump (diff)
downloadgentoo-a76e5418e340a9012bcb87b75d6c2a5f355e03af.tar.gz
gentoo-a76e5418e340a9012bcb87b75d6c2a5f355e03af.tar.bz2
gentoo-a76e5418e340a9012bcb87b75d6c2a5f355e03af.zip
dev-python/pyDeComp: New package, initial live ebuild
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyDeComp/metadata.xml18
-rw-r--r--dev-python/pyDeComp/pyDeComp-9999.ebuild45
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pyDeComp/metadata.xml b/dev-python/pyDeComp/metadata.xml
new file mode 100644
index 000000000000..5b985b699484
--- /dev/null
+++ b/dev-python/pyDeComp/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>releng</herd>
+ <maintainer>
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ </maintainer>
+ <longdescription>A python interface library for common compression ,
+ decompression and contents generation. It aims to create a simple,
+ easily extended and configurable common interface to various compressison
+ routines. It can easily be extended with with custom compression,
+ decompression, and contents definitions.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">dol-sen/pyDeComp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyDeComp/pyDeComp-9999.ebuild b/dev-python/pyDeComp/pyDeComp-9999.ebuild
new file mode 100644
index 000000000000..bce39353b202
--- /dev/null
+++ b/dev-python/pyDeComp/pyDeComp-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+
+EGIT_BRANCH="master"
+
+inherit distutils-r1 python-r1 git-2
+
+EGIT_REPO_URI="git://github.com/dol-sen/pyDeComp.git"
+
+DESCRIPTION="A python interface library for common compression, decompression and contents handling"
+HOMEPAGE="https://github.com/dol-sen/pyDeComp"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+KEYWORDS=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ "
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/pyDeComp/issues"
+ einfo "I am also on IRC @ #gentoo-releng of the freenode network"
+ einfo
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in github or bugzilla."
+}