summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 13:34:51 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 13:35:44 +0200
commita8c7d82d4b7defd48fa84760655922f7b159a792 (patch)
tree2bf30b18b2bde50bc32883ed0c5a55763e06b4ca /dev-python
parentdev-python/slimit: Enable py3.9 & py3.10 (diff)
downloadgentoo-a8c7d82d4b7defd48fa84760655922f7b159a792.tar.gz
gentoo-a8c7d82d4b7defd48fa84760655922f7b159a792.tar.bz2
gentoo-a8c7d82d4b7defd48fa84760655922f7b159a792.zip
dev-python/slixmpp: Sync the live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/slixmpp/slixmpp-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/slixmpp/slixmpp-9999.ebuild b/dev-python/slixmpp/slixmpp-9999.ebuild
index 4bdc2f5616c8..0f5e88aa5f6c 100644
--- a/dev-python/slixmpp/slixmpp-9999.ebuild
+++ b/dev-python/slixmpp/slixmpp-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -31,6 +31,8 @@ RDEPEND="
${DEPEND}
"
+distutils_enable_tests unittest
+
python_test() {
"${EPYTHON}" ./run_tests.py || die "Tests failed with ${EPYTHON}"
}