summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-28 10:34:11 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-28 10:34:11 +0100
commita94dc9e67e5383c836f9b23408b40c648e0256ae (patch)
treec55eafe66fd55dd7c78e51bf0ca938a93f1b81e6 /dev-python
parentmedia-video/ffmpeg: Enable nonfree when enabling nvenc. (diff)
downloadgentoo-a94dc9e67e5383c836f9b23408b40c648e0256ae.tar.gz
gentoo-a94dc9e67e5383c836f9b23408b40c648e0256ae.tar.bz2
gentoo-a94dc9e67e5383c836f9b23408b40c648e0256ae.zip
dev-python/simplejson: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/simplejson/Manifest1
-rw-r--r--dev-python/simplejson/simplejson-3.8.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index a88198225085..1fbe8389a424 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,2 +1,3 @@
DIST simplejson-3.7.2.tar.gz 74877 SHA256 8358ecc05541be4068109acf26a4ae89ba14450d20e92e0973d0d67bea3d7431 SHA512 5e2874c4d627035b3e205b5208b46beb172ac934742b0cb68f43f70aa2f401ec568c2b69fccdb1d870bf5196df0f6e37b790332a6e4d7969a296c8c104bdfe0b WHIRLPOOL 26f5e23250031d9b20b121a7110a1b623f32128721281b2554f2727f815b03b39b0680d21b41bb8729288f2774d38e92301bcf72188d054aa03497818edefdca
DIST simplejson-3.8.0.tar.gz 75875 SHA256 217e4797da3a9a4a9fbe6722e0db98070b8443a88212d7acdbd241a7668141d9 SHA512 c985a0f56170f78b6c6e8f0e4b4bf50f258c8f2639524f5b14d8e07b547e336acf96ac55cf562243fff06752ceba4a05f1e6dd43f6c918159a7b3640af0f0c1d WHIRLPOOL 368779f57bc1186d3b30ae80f74d0eca50709dfe6063d52c359d665eaacc9caa751fbbb9f4437e8bf8908f3569f85424632208d8f7c6146ebc8e8cc9c77b723d
+DIST simplejson-3.8.1.tar.gz 76033 SHA256 428ac8f3219c78fb04ce05895d5dff9bd813c05a9a7922c53dc879cd32a12493 SHA512 9c135347a015f5fbb4373da61282230430320c89bc1114f7487eb632bccbe29a4b2c396d724c6c72af5c7df78f1676869a037be9d137b4f29f18e82a9eb2b1f5 WHIRLPOOL 8441ccaff4e4115d58461f528179c4fc25139b5f7f86cc85826798e392e664154468f1fa2471f18fc7bd518adf06a75b493218765ca4df022d92e6ee24552e38
diff --git a/dev-python/simplejson/simplejson-3.8.1.ebuild b/dev-python/simplejson/simplejson-3.8.1.ebuild
new file mode 100644
index 000000000000..5043687bf112
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.8.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="http://undefined.org/python/#simplejson https://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst CHANGES.txt )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}