summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-27 08:54:29 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-27 09:03:19 +0200
commita97e2a09ef3498593f9a914e02da80b4a1a588a8 (patch)
treeae8d646badcf2aaf74df50b85099d268b009c04f /dev-python
parentdev-python/setuptools_scm: Bump to 4.1.1 (diff)
downloadgentoo-a97e2a09ef3498593f9a914e02da80b4a1a588a8.tar.gz
gentoo-a97e2a09ef3498593f9a914e02da80b4a1a588a8.tar.bz2
gentoo-a97e2a09ef3498593f9a914e02da80b4a1a588a8.zip
dev-python/webtest: Bump to 2.0.35
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/webtest/Manifest1
-rw-r--r--dev-python/webtest/webtest-2.0.35.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/webtest/Manifest b/dev-python/webtest/Manifest
index b463cc828c88..18b0e17c5bb7 100644
--- a/dev-python/webtest/Manifest
+++ b/dev-python/webtest/Manifest
@@ -1 +1,2 @@
DIST WebTest-2.0.33.tar.gz 76081 BLAKE2B 6c06d7cf6573282342ac190fe2365d041679fd9a75571a525cf0214f22a0631d5f97e94261090d9c2a372f77b005d22be5976f612c27c6b4c832c71469b33ee8 SHA512 9f5c614f8215837dc5cecc9c3e844c5e1678eb8275f9e27a0ec6a68648e9f4f09155aa72f6c731c34028b8671b7776a94235f3e54d7dbf5ff55de94840171ca8
+DIST WebTest-2.0.35.tar.gz 76227 BLAKE2B 2f10520a66a00cf61834d5ebe2b8eea469d4ca32155c9af3c0b78234607ea5443e695730a7db4476f5296f9b848f3950027d7485a4116e7d736fd9c33d8e78ae SHA512 ecad031702a9d2031d4e2230dc8213aaa6b1a3e9e6add296ee796aa2ef77d81c992dc24e481f721bc34711d1e33f3932d56cec4be3d62ee82a71fb405942c339
diff --git a/dev-python/webtest/webtest-2.0.35.ebuild b/dev-python/webtest/webtest-2.0.35.ebuild
new file mode 100644
index 000000000000..2b07d79efb43
--- /dev/null
+++ b/dev-python/webtest/webtest-2.0.35.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="https://pypi.org/project/WebTest/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2[${PYTHON_USEDEP}]
+ >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ app-arch/unzip
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ dev-python/wsgiproxy2[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/webtest-2.0.33-no-pylons-theme.patch"
+)
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest