summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-13 11:32:47 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-13 12:04:50 +0200
commitabc0ff320ab02a4a17b13240ccc4d51b440563d7 (patch)
tree14ba2c4255a6c09c25147675f0801cb4a507d048 /dev-python
parentdev-python/cheroot: Bump to 8.4.4 (diff)
downloadgentoo-abc0ff320ab02a4a17b13240ccc4d51b440563d7.tar.gz
gentoo-abc0ff320ab02a4a17b13240ccc4d51b440563d7.tar.bz2
gentoo-abc0ff320ab02a4a17b13240ccc4d51b440563d7.zip
dev-python/hypothesis: Bump to 5.24.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.24.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 2cbfea9d878c..d1b367f3a31d 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-python-5.21.0.tar.gz 9025422 BLAKE2B acd6f3b0f945ae65656af2a718a
DIST hypothesis-python-5.23.12.tar.gz 9040323 BLAKE2B 2cef5fd59419ad7522693f543bfecb1a829158ee07a3d31ab023f08ccc10f97c5e24dc14daee2d0447c10bc9e44d784335edd667771e693e82e99a93c58bb11f SHA512 8a7c7df518a5cbb5ddd16793a742077adfef68244021487fd97efd6fb1b6c743760c01b4f5a7613c30308a38370d1ede5f7f77c2fcda4ae90f928d36c7bebc4f
DIST hypothesis-python-5.23.9.tar.gz 9041210 BLAKE2B e1f121a81cbdf14e1216e3c22eb3afd6997908efbe2ebedc14e3eeb2cbdfaf9efbbdd3d40c6ae4b644d37c13ba18e1aec39f945158d731a413d2933d6da204a8 SHA512 9093005589643c185dbea8c8ee5fd2e9c23c37fe6dc0798dfcbd2afe57d97f652fb1c10d7b482e3fb333499639de1796ac2d091e7e7f41e1c88ac14aed337a31
DIST hypothesis-python-5.24.0.tar.gz 9040780 BLAKE2B 126a7e0a4d9df292445453035d43ed219dda6a4d5b885570905625474854e380d5c230b4f587d66f1d6b32f2edd9a817fff8054a4876ad7382c2940f25e1cc02 SHA512 649bd9e1770c4b2ca55ad70f80b912f183dda73cb602538ba4d887f1df91b3ae9048b0fa3199d371019c06e15421de842e0451fc468a28e8a62506bcdae179d4
+DIST hypothesis-python-5.24.2.tar.gz 9050270 BLAKE2B 05043935afec77b23349b4973a2b3b9fafceba467754dcf3295d410561e3c76ff3c4b2996f5f14aea46b5b6a073e7db2a8be085d42df79ed6eb78eacd7539234 SHA512 88c1351b70355906cc57b667f2a863ac1334219e1721504ea76b1599d57fdf272a96263c365fe24882be9f83f28671998ebee28b0faea2190d9b6b39d2c2dc84
diff --git a/dev-python/hypothesis/hypothesis-5.24.2.ebuild b/dev-python/hypothesis/hypothesis-5.24.2.ebuild
new file mode 100644
index 000000000000..54efc2972e96
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.24.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}