summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 12:30:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 12:48:03 +0200
commitabd33c7e4c86251d44e91efe844fd6a98d070343 (patch)
treee252eb0a3d2dc0e0a3dacfa415d4ea0d79ca1818 /dev-python
parentdev-db/mycli: Enable py3.9 (diff)
downloadgentoo-abd33c7e4c86251d44e91efe844fd6a98d070343.tar.gz
gentoo-abd33c7e4c86251d44e91efe844fd6a98d070343.tar.bz2
gentoo-abd33c7e4c86251d44e91efe844fd6a98d070343.zip
dev-python/APScheduler: Enable py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/APScheduler/APScheduler-3.6.3.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/dev-python/APScheduler/APScheduler-3.6.3.ebuild b/dev-python/APScheduler/APScheduler-3.6.3.ebuild
index a1d1d280c8a0..8f1d7466fc1a 100644
--- a/dev-python/APScheduler/APScheduler-3.6.3.ebuild
+++ b/dev-python/APScheduler/APScheduler-3.6.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..8} )
DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -15,18 +15,17 @@ SRC_URI="mirror://pypi/A/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
>=dev-python/six-1.4.0[${PYTHON_USEDEP}]
>=dev-python/tzlocal-1.2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
+BDEPEND="
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
www-servers/tornado[${PYTHON_USEDEP}]
)"
+distutils_enable_tests pytest
+
# Tests that are known to fail (some may be triggered by network-sandbox).
test_failures=(
test_add_class_method_job
@@ -64,7 +63,3 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-
-python_test() {
- py.test || die "Testing failed with ${EPYTHON}"
-}