summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-21 12:43:40 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-21 12:43:47 +0100
commitabf8d1cf02b68d82bc21e117442cede219f6d76f (patch)
tree867d7bbeb66aceef845f8acf754a120d2e6bae31 /dev-python
parentdev-python/urllib3: Version Bump (diff)
downloadgentoo-abf8d1cf02b68d82bc21e117442cede219f6d76f.tar.gz
gentoo-abf8d1cf02b68d82bc21e117442cede219f6d76f.tar.bz2
gentoo-abf8d1cf02b68d82bc21e117442cede219f6d76f.zip
dev-python/pip: Update unbundle patch
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pip/files/pip-8.0.0-unbundle.patch43
-rw-r--r--dev-python/pip/pip-8.0.0-r1.ebuild (renamed from dev-python/pip/pip-8.0.0.ebuild)2
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/pip/files/pip-8.0.0-unbundle.patch b/dev-python/pip/files/pip-8.0.0-unbundle.patch
new file mode 100644
index 000000000000..d508d51ab4fc
--- /dev/null
+++ b/dev-python/pip/files/pip-8.0.0-unbundle.patch
@@ -0,0 +1,43 @@
+ pip/_vendor/__init__.py | 15 +++++----------
+ 1 file changed, 5 insertions(+), 10 deletions(-)
+
+diff --git a/pip/_vendor/__init__.py b/pip/_vendor/__init__.py
+index b09a7c3..b9fe6ee 100644
+--- a/pip/_vendor/__init__.py
++++ b/pip/_vendor/__init__.py
+@@ -14,7 +14,7 @@ import sys
+ # Downstream redistributors which have debundled our dependencies should also
+ # patch this value to be true. This will trigger the additional patching
+ # to cause things like "six" to be available as pip.
+-DEBUNDLED = False
++DEBUNDLED = True
+
+ # By default, look in this directory for a bunch of .whl files which we will
+ # add to the beginning of sys.path before attempting to import anything. This
+@@ -29,13 +29,10 @@ WHEEL_DIR = os.path.abspath(os.path.dirname(__file__))
+ def vendored(modulename):
+ vendored_name = "{0}.{1}".format(__name__, modulename)
+
+- try:
+- __import__(vendored_name, globals(), locals(), level=0)
+- except ImportError:
+- __import__(modulename, globals(), locals(), level=0)
+- sys.modules[vendored_name] = sys.modules[modulename]
+- base, head = vendored_name.rsplit(".", 1)
+- setattr(sys.modules[base], head, sys.modules[modulename])
++ __import__(modulename, globals(), locals(), level=0)
++ sys.modules[vendored_name] = sys.modules[modulename]
++ base, head = vendored_name.rsplit(".", 1)
++ setattr(sys.modules[base], head, sys.modules[modulename])
+
+
+ # If we're operating in a debundled setup, then we want to go ahead and trigger
+@@ -85,8 +82,6 @@ if DEBUNDLED:
+ vendored("requests.packages.urllib3.packages.ordered_dict")
+ vendored("requests.packages.urllib3.packages.six")
+ vendored("requests.packages.urllib3.packages.ssl_match_hostname")
+- vendored("requests.packages.urllib3.packages.ssl_match_hostname."
+- "_implementation")
+ vendored("requests.packages.urllib3.poolmanager")
+ vendored("requests.packages.urllib3.request")
+ vendored("requests.packages.urllib3.response")
diff --git a/dev-python/pip/pip-8.0.0.ebuild b/dev-python/pip/pip-8.0.0-r1.ebuild
index aeffddf7294a..842b1a990908 100644
--- a/dev-python/pip/pip-8.0.0.ebuild
+++ b/dev-python/pip/pip-8.0.0-r1.ebuild
@@ -42,7 +42,7 @@ RESTRICT="test"
PATCHES=(
"${FILESDIR}"/${PN}-6.0.2-disable-version-check.patch
- "${FILESDIR}"/${PN}-7.1.2-unbundle.patch
+ "${FILESDIR}"/${P}-unbundle.patch
)
python_prepare_all() {