summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-09-01 14:23:38 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-09-01 14:23:55 -0500
commitb0d371d790bab246e78fda2148e07fc6c60ec461 (patch)
treecc67adc318fff845115fa6e1e950a7fa2799c5c7 /dev-python
parentmedia-video/vlc: 3.0.4 version bump (diff)
downloadgentoo-b0d371d790bab246e78fda2148e07fc6c60ec461.tar.gz
gentoo-b0d371d790bab246e78fda2148e07fc6c60ec461.tar.bz2
gentoo-b0d371d790bab246e78fda2148e07fc6c60ec461.zip
dev-python/cliff: fix tests
Fixes: https://bugs.gentoo.org/664976 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cliff/cliff-2.12.0-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/cliff/cliff-2.12.0-r1.ebuild b/dev-python/cliff/cliff-2.12.0-r1.ebuild
new file mode 100644
index 000000000000..d5fdba0dfe3a
--- /dev/null
+++ b/dev-python/cliff/cliff-2.12.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+VIRTUALX_REQUIRED="test"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/dreamhost/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~mips ~s390 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ )
+"
+# source files stipulate <sphinx-1.3 however build effected perfectly with sphinx-1.3.1
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/cmd2-0.6.7[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/unicodecsv-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ "
+
+python_compile() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ stestr init || die "stestr init failed under ${EPYTHON}"
+ # needs outside access, so blacklist the test
+ virtx stestr run --black-regex cliff.tests.test_app.TestIO.test_writer_encoding || die "stestr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}