summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-06 00:20:49 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-06 01:44:18 +0100
commitb12ce2afbd514bd24f6bb1266b4fb6d6c3c50d32 (patch)
tree39a330f6f62572e00ea44c5229f7166fb3f4c234 /dev-python
parentwww-client/firefox-bin: bump to 57.0.4 for Meltdown/Spectre, backport pkcs11 ... (diff)
downloadgentoo-b12ce2afbd514bd24f6bb1266b4fb6d6c3c50d32.tar.gz
gentoo-b12ce2afbd514bd24f6bb1266b4fb6d6c3c50d32.tar.bz2
gentoo-b12ce2afbd514bd24f6bb1266b4fb6d6c3c50d32.zip
dev-python/pyramid: Clean old up
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyramid/Manifest2
-rw-r--r--dev-python/pyramid/pyramid-1.5.1.ebuild45
-rw-r--r--dev-python/pyramid/pyramid-1.5.7-r1.ebuild38
3 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/pyramid/Manifest b/dev-python/pyramid/Manifest
index 239074ac5abe..b0f2321408b9 100644
--- a/dev-python/pyramid/Manifest
+++ b/dev-python/pyramid/Manifest
@@ -1,3 +1 @@
-DIST pyramid-1.5.1.tar.gz 2401767 BLAKE2B 046a57d5b8f572db46edbd8f7f80cbeab2eca860484a18cf23ccb26247c2ac470e113ad14a8ff872186e8f8bf25aa106014ed8c5520dbdac4a80eafb005d5212 SHA512 70b04111020d0f02ef21c52c44d7b6a5e78d198daee0068921df048bcae8b07567aee05d57f1a9e7329ef418116a0f7682aee30c6f785a4d1ec847e2519e7cc5
-DIST pyramid-1.5.7.tar.gz 2678474 BLAKE2B 0ea6a7fecec551520772e0df3619fe7f212d0c2ed969366569ff4eb28079f3ae554ecceb791d89ae893ddb7b718403768f1636aee63fd1849da38aa83c32eea9 SHA512 32b0d4b85bf0f471b7c08ac7353f2859284ee7bb2451b68429074fb5f954e0e02d7bc4bdd86f843d6a5304b56a418e698d614806bbfd09dda9a608db88c25949
DIST pyramid-1.5.8.tar.gz 2546802 BLAKE2B 71e19b01a5ebdd671ee12c9c71b5dc557b12db76db94ad238e9695e93cd3ecd53c83fbc6c143d298601ff328d353dea8c6eb557dd1edff80f02941cf75f19f19 SHA512 725f472245c03a50463d9e8946dbc71063ef46d58df8a41804d1c68bb0abe796f7fcd36f7c1708f8597a980f8cb308fbeec0bbad3f82c0e7d3eb449f6719fe16
diff --git a/dev-python/pyramid/pyramid-1.5.1.ebuild b/dev-python/pyramid/pyramid-1.5.1.ebuild
deleted file mode 100644
index 183fe915b6fe..000000000000
--- a/dev-python/pyramid/pyramid-1.5.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1
-
-RESTRICT="test" # Can't package dependencies
-
-DESCRIPTION="A small open source Python web framework"
-HOMEPAGE="http://www.pylonsproject.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="repoze"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-#IUSE="test"
-# tests would pull in dev-python/zope-deprecation with its deps - not a good idea
-
-RDEPEND="
- dev-python/chameleon[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- dev-python/repoze-lru[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- dev-python/translationstring[${PYTHON_USEDEP}]
- dev-python/pastedeploy[${PYTHON_USEDEP}]
- dev-python/venusian[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- "
- #test? ( dev-python/webtest[${PYTHON_USEDEP}]
- # dev-python/nose[${PYTHON_USEDEP}]
- # dev-python/coverage[${PYTHON_USEDEP}]
- # dev-python/virtualenv[${PYTHON_USEDEP}]
- # )
- #"
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/pyramid/pyramid-1.5.7-r1.ebuild b/dev-python/pyramid/pyramid-1.5.7-r1.ebuild
deleted file mode 100644
index 99de90acd49b..000000000000
--- a/dev-python/pyramid/pyramid-1.5.7-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="A small open source Python web framework"
-HOMEPAGE="http://www.pylonsproject.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="repoze"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/chameleon[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- dev-python/repoze-lru[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/zope-deprecation[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- dev-python/translationstring[${PYTHON_USEDEP}]
- dev-python/pastedeploy[${PYTHON_USEDEP}]
- dev-python/venusian[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/webtest[${PYTHON_USEDEP}]
- $(python_gen_cond_dep \
- 'dev-python/zope-component[${PYTHON_USEDEP}]' \
- 'python2*' pypy)
- )"
-
-python_test() {
- esetup.py test
-}