summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-22 08:44:37 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-22 09:34:38 +0200
commitb2894a29e7dae734dbaf9ddac53120ceec511f83 (patch)
tree2150473cc2653891fdbe0271ba7d012bf1084e6f /dev-python
parentpackage.mask: Last rite dev-python/idna-ssl (diff)
downloadgentoo-b2894a29e7dae734dbaf9ddac53120ceec511f83.tar.gz
gentoo-b2894a29e7dae734dbaf9ddac53120ceec511f83.tar.bz2
gentoo-b2894a29e7dae734dbaf9ddac53120ceec511f83.zip
dev-python/stestr: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/stestr/Manifest1
-rw-r--r--dev-python/stestr/stestr-3.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/stestr/Manifest b/dev-python/stestr/Manifest
index 53b35b8908d7..fca596b5bf1f 100644
--- a/dev-python/stestr/Manifest
+++ b/dev-python/stestr/Manifest
@@ -1 +1,2 @@
DIST stestr-2.1.0.tar.gz 103501 BLAKE2B 6b000b8e3d0a27a18f19510dd8d5de8641223c18ad22a3f90b73619aa41bbe1a51bcedba604ec448282fa41e2ae93b61fdd0e72e603a39730a59400fc15ef007 SHA512 a99d0659da0ca2b86703529df9ef6d135578bd8374a2afcbd10bd96f24f5e6dd1dacd5929d96a083881f1db2a930b039d9045348a0298d84d2480c6c9a75d1f7
+DIST stestr-3.2.0.tar.gz 118000 BLAKE2B 901654b53fdc9e5ab287b77b0a26ce531e3a167b2f5d0aa0765de170341bac8ebfbc4efcae39f672ca6dc6f7518913cb5e56d87faaef35c0b06287652c06edb1 SHA512 4f5e41c92518104b06f5b9717d59c214a8d87efe47fee199a602e71efd64e29c98711ffcf3b88cd00209946d0ab123c7ec5aa842e1d54bc65d83c8d70fa4898c
diff --git a/dev-python/stestr/stestr-3.2.0.ebuild b/dev-python/stestr/stestr-3.2.0.ebuild
new file mode 100644
index 000000000000..3847c9c410ac
--- /dev/null
+++ b/dev-python/stestr/stestr-3.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="A parallel Python test runner built around subunit"
+HOMEPAGE="https://github.com/mtreinish/stestr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/voluptuous-0.8.9[${PYTHON_USEDEP}]"
+
+python_test() {
+ distutils_install_for_testing
+ stestr init || die
+ stestr run || die "Tests failed with ${EPYTHON}"
+}