summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2021-10-25 21:20:11 -0400
committerRick Farina <zerochaos@gentoo.org>2021-10-26 13:48:19 -0400
commitb29cdf3024a8de39f3dd86ad0b8a5bbf1a1ad32f (patch)
treeed03245697053ec8cbd801f6d8fddf421936747d /dev-python
parentprofiles/base: Mask sys-fabric/ofed[dapl] (diff)
downloadgentoo-b29cdf3024a8de39f3dd86ad0b8a5bbf1a1ad32f.tar.gz
gentoo-b29cdf3024a8de39f3dd86ad0b8a5bbf1a1ad32f.tar.bz2
gentoo-b29cdf3024a8de39f3dd86ad0b8a5bbf1a1ad32f.zip
dev-python/inotify: initial import
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/inotify/Manifest1
-rw-r--r--dev-python/inotify/inotify-0.2.10.ebuild25
-rw-r--r--dev-python/inotify/metadata.xml11
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/inotify/Manifest b/dev-python/inotify/Manifest
new file mode 100644
index 000000000000..462a220ab3a8
--- /dev/null
+++ b/dev-python/inotify/Manifest
@@ -0,0 +1 @@
+DIST inotify-0.2.10.tar.gz 18774 BLAKE2B 51b35541d70d8855b7b5a2d52abf8d1667334a02cb1623d30f7f74ca8a15dc5f70728b465dae91cca687a94b485eba1caf8e0735387cbb3ff0d15ad95d97f693 SHA512 1c8e78e1787f30d8dd0fae73b02f03c0b89f7feab3ab122bff56d7e7bcb2f752da6f167731b2d60b179a696d8ed935b8071587c873d9f8618869f6615f316d5f
diff --git a/dev-python/inotify/inotify-0.2.10.ebuild b/dev-python/inotify/inotify-0.2.10.ebuild
new file mode 100644
index 000000000000..68db6e6b324e
--- /dev/null
+++ b/dev-python/inotify/inotify-0.2.10.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_9 )
+inherit distutils-r1
+
+DESCRIPTION="an efficient and elegant inotify"
+HOMEPAGE="https://github.com/dsoprea/PyInotify"
+SRC_URI="https://github.com/dsoprea/PyInotify/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/PyInotify-${PV}"
+
+#tests don't work and I don't care
+RESTRICT="test"
+distutils_enable_tests pytest
diff --git a/dev-python/inotify/metadata.xml b/dev-python/inotify/metadata.xml
new file mode 100644
index 000000000000..922ce76ec7b0
--- /dev/null
+++ b/dev-python/inotify/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina (Zero_Chaos)</name>
+ </maintainer>
+</pkgmetadata>