summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-18 22:50:17 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-18 23:44:23 +0100
commitb3fb3c1fb4072ea127b173b7ca00c10ce9517002 (patch)
tree19c4741a0d8b49cf4fdde1d2cea84738f98e85f6 /dev-python
parentapp-admin/awscli: Bump to 1.22.38 (diff)
downloadgentoo-b3fb3c1fb4072ea127b173b7ca00c10ce9517002.tar.gz
gentoo-b3fb3c1fb4072ea127b173b7ca00c10ce9517002.tar.bz2
gentoo-b3fb3c1fb4072ea127b173b7ca00c10ce9517002.zip
dev-python/pytest-timeout: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-timeout/Manifest1
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-2.1.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
index 0ef949925e15..e52c707ea5ef 100644
--- a/dev-python/pytest-timeout/Manifest
+++ b/dev-python/pytest-timeout/Manifest
@@ -1 +1,2 @@
DIST pytest-timeout-2.0.2.tar.gz 16683 BLAKE2B bc6ee17832dfa5c3e5a35efc34bda630f1f1f7e7ece5a71d68110ab12c08566ee89c3b0f68967807967d17e2622ca1d2bce24baf51986ad8921fd55df091b376 SHA512 ee151a55f6323ae23ddd7e54e39e1c014de2aa2a142a0e3ba81c80b5d36435fc6c2809e383df8c49e62df70361a03dbe73e4d96d03798323fe7f1304a197f770
+DIST pytest-timeout-2.1.0.tar.gz 18386 BLAKE2B 1c84b67e8d07056f9c5b188e467832d4aa292ce1047da6cb13b2939962d2599853db134b16ff3a1a953cbdc1c1772be961eadc9925b32f8dbe514938ede90d40 SHA512 5750e5183669ed9b83fbb76bd7fc9fc1f5f6eef3d9b675dc44f6c7edfd2c6d15739d71e845ededaa192c93da73026ac3376a3295be9f7d3f3eac325660ce7bf3
diff --git a/dev-python/pytest-timeout/pytest-timeout-2.1.0.ebuild b/dev-python/pytest-timeout/pytest-timeout-2.1.0.ebuild
new file mode 100644
index 000000000000..08318635d20c
--- /dev/null
+++ b/dev-python/pytest-timeout/pytest-timeout-2.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to abort hanging tests"
+HOMEPAGE="https://pypi.org/project/pytest-timeout/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# do not rdepend on pytest, it won't be used without it anyway
+# pytest-cov used to test compatibility
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ !hppa? (
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+ )"
+
+distutils_enable_tests pytest