summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-21 02:37:50 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-21 02:44:24 -0400
commitb5f1bb04fef40e478bb8dd42b985fcb0c9bb848e (patch)
tree53ea57066b318c59e49a9ce9b44768439429c2ca /dev-python
parentros-meta/ros_control: Bump to 0.11.1. (diff)
downloadgentoo-b5f1bb04fef40e478bb8dd42b985fcb0c9bb848e.tar.gz
gentoo-b5f1bb04fef40e478bb8dd42b985fcb0c9bb848e.tar.bz2
gentoo-b5f1bb04fef40e478bb8dd42b985fcb0c9bb848e.zip
dev-python/html2text: version bump to 2016.5.29
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/html2text/Manifest1
-rw-r--r--dev-python/html2text/html2text-2016.5.29.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/html2text/Manifest b/dev-python/html2text/Manifest
index 990fc0dd6bb1..0dcfc6e8abac 100644
--- a/dev-python/html2text/Manifest
+++ b/dev-python/html2text/Manifest
@@ -1 +1,2 @@
DIST html2text-2014.4.5.tar.gz 30177 SHA256 b6f37556650a32cd625c56f2db3fa2ca2d57a7ff0a4be7a3b9118dd911c8efd6 SHA512 740750f838f0370c6b05bb1538d3de99cfd074acc95923440b14818b934e49df1ad0864bfe1a4fcf0b8fd3c9c402a4b2edaeabe992aa0870acc7ce3b6cd3924a WHIRLPOOL 502c08327cbd98ac08e19ff42b633cb7f08204123aa4a8d15826c4137976367cd7e7073660aa61788301d1817ade02be93a014caeb2ca6c53311df5fcf8adc55
+DIST html2text-2016.5.29.tar.gz 46879 SHA256 7f59fb29083a7819063b227c24a8dd5e25aeef74b68bf2318a68cc1e3e653add SHA512 58b71fda6ea6fd1a71dec757c91cf342265a2c89ff5c45e752436068419fb6c1faa1ca0d5a6baafaaa60186a85aefdd840989177ce30e55bcda1c6209fc375be WHIRLPOOL 23f8625952dbd3543687976fa2595a0859d18376e716e83848aec29f7f704e40c71142c3d01bdcbdc8f8542b1e03a5ee695da40d4b6b9d436108a10b1ad57456
diff --git a/dev-python/html2text/html2text-2016.5.29.ebuild b/dev-python/html2text/html2text-2016.5.29.ebuild
new file mode 100644
index 000000000000..d4a7ee090b15
--- /dev/null
+++ b/dev-python/html2text/html2text-2016.5.29.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Turn HTML into equivalent Markdown-structured text"
+HOMEPAGE="https://github.com/html2text/html2text
+ https://github.com/Alir3z4/html2text https://pypi.python.org/pypi/html2text"
+SRC_URI="https://github.com/Alir3z4/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+
+DOCS=( AUTHORS.rst ChangeLog.rst README.md )
+
+src_prepare() {
+ default
+
+ # naming conflict with app-text/html2text, bug 421647
+ sed -i 's/html2text=html2text.cli:main/py\0/' setup.py || die
+}
+
+python_test() {
+ "${PYTHON}" test/test_html2text.py -v || die "tests failed with ${EPYTHON}"
+}