summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-15 09:43:17 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-15 10:44:23 +0200
commitbac6ac4b356168c72ed4b4fa2db4b0b615cd2f5f (patch)
tree638a574afce02a3fb38680ff672999676d99e001 /dev-python
parentdev-python/pytest-xdist: Bump to 2.0.0 (diff)
downloadgentoo-bac6ac4b356168c72ed4b4fa2db4b0b615cd2f5f.tar.gz
gentoo-bac6ac4b356168c72ed4b4fa2db4b0b615cd2f5f.tar.bz2
gentoo-bac6ac4b356168c72ed4b4fa2db4b0b615cd2f5f.zip
dev-python/wheel: Bump to 0.35.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wheel/Manifest1
-rw-r--r--dev-python/wheel/wheel-0.35.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/wheel/Manifest b/dev-python/wheel/Manifest
index e826ef94540f..42765e020571 100644
--- a/dev-python/wheel/Manifest
+++ b/dev-python/wheel/Manifest
@@ -1,2 +1,3 @@
DIST wheel-0.34.2.gh.tar.gz 57175 BLAKE2B 4d06c411561f80e51c15422f2d3318efa565f9119e869a2f9284adb9bd3aff7bc104013a63fefae36742d7d87c8468b42292723ed031c2b109323a9141fd1cea SHA512 fcd02cf770382c26b5250aa48f60481ac868ff7e1b08245ed4616aaa7d6dc5e3280d9ab787c4d1690b11550de9f6160c0d31dd65b79554711ab5d02de479e1ab
DIST wheel-0.35.0.gh.tar.gz 55911 BLAKE2B b9253c362bd016eca6e43bf4003f08dd88bf45c893edacb59ea1cb594410981b80be4acbc4e0127cee05c394377407bf23f1119a71010eecf0d1669ecd8ed861 SHA512 d6818fd825bf49dfd4e88fd252ce97c64df34eae72b482e932df2fd39562bae54a63f3e9b65b65d04b6e10d130edd462a769499d214d7beae053555618e2fc15
+DIST wheel-0.35.1.gh.tar.gz 63563 BLAKE2B d1432a638b91e821cb9b9fc748567b9ad18bbfd4737cee915ee3e2c585c4758e79bcf163edac56a09f9e356d81a057214c8e84c5c75b45505c67aa761e97fe3f SHA512 34cd6d1a649842abd895418c0183e68f44e228be905041e1dd8562987fbab8aa617da9b78479cb8d56fb6bb8714ec1085b87640c385bfc933e215f6e33ccf55b
diff --git a/dev-python/wheel/wheel-0.35.1.ebuild b/dev-python/wheel/wheel-0.35.1.ebuild
new file mode 100644
index 000000000000..60f3b6e68015
--- /dev/null
+++ b/dev-python/wheel/wheel-0.35.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A built-package format for Python"
+HOMEPAGE="https://pypi.org/project/wheel/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/pypa/wheel/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed \
+ -e 's:--cov=wheel::g' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ if ! python_is_python3; then
+ # install fails due to unicode in paths
+ ewarn "Testing is broken with py2.7, please test externally"
+ return
+ fi
+
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}