summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-29 00:45:01 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-29 00:45:01 +0200
commitbc047510aea0926ba78b824be5dfec142e76c8af (patch)
tree268734ea7dbe275bc42edb2ef31866f8c8bc9a59 /dev-python
parentdev-python/jaraco-collections: add Python 3.7, make tests verbose (diff)
downloadgentoo-bc047510aea0926ba78b824be5dfec142e76c8af.tar.gz
gentoo-bc047510aea0926ba78b824be5dfec142e76c8af.tar.bz2
gentoo-bc047510aea0926ba78b824be5dfec142e76c8af.zip
dev-python/irc: add python 3.7, make tests verbose, sort deps
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/irc/irc-16.3.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/dev-python/irc/irc-16.3.ebuild b/dev-python/irc/irc-16.3.ebuild
index 98fedd35523f..a8ee6feca92d 100644
--- a/dev-python/irc/irc-16.3.ebuild
+++ b/dev-python/irc/irc-16.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
inherit distutils-r1
@@ -27,18 +27,19 @@ RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- )
doc? (
>=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
>=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
)
+ test? (
+ ${RDEPEND}
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ )
"
python_compile_all() {
@@ -51,7 +52,7 @@ python_compile_all() {
python_test() {
# Override pytest options to skip flake8
- py.test --override-ini="addopts=--doctest-modules" \
+ pytest -vv --override-ini="addopts=--doctest-modules" \
|| die "Tests failed with ${EPYTHON}"
}