summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-01-22 12:34:53 -0600
committerMatthias Maier <tamiko@gentoo.org>2017-01-22 12:36:25 -0600
commitbf78f9761df6150c92a170066f77dafddaca1738 (patch)
treec0c0a75dfd1df92ae71f2686c4945d92571ae121 /dev-python
parentapp-emulation/libvirt: version bump to 3.0.0, bug #606632 (diff)
downloadgentoo-bf78f9761df6150c92a170066f77dafddaca1738.tar.gz
gentoo-bf78f9761df6150c92a170066f77dafddaca1738.tar.bz2
gentoo-bf78f9761df6150c92a170066f77dafddaca1738.zip
dev-python/libvirt-python: version bump to 3.0.0, bug #606632
Package-Manager: Portage-2.3.0, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-3.0.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 75f1005257c3..56a95398ab32 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -2,3 +2,4 @@ DIST libvirt-python-1.3.5.tar.gz 168780 SHA256 a0508a57637fd18a3584fb9d2322fb172
DIST libvirt-python-2.1.0.tar.gz 170607 SHA256 74887fa1be60db2701e726da7e01e3bf18ecd3b8d1cfdf2f1f7480e1a1edbacb SHA512 8a031b7572c11f57a16292980188e4da830d1293aa1aab3fa35f9c18746e5628086643d8c6d6450d668d194dd3c792e0a5f61605f96dc11fa430c846e459529a WHIRLPOOL 96f02cc2870a9ecc722da1dbf2aa3f7d01fcbec6b5215329d75664e468d938a6ed7a5ff691618176539edaba0beb6ea0d01b02f328758099b343b86ac9e853e3
DIST libvirt-python-2.3.0.tar.gz 171858 SHA256 ad25a98c2508a6c81d65cc8bc5f3e0b4c506247cf544a7d54c41526a99caef48 SHA512 87d3356c780f4f12a5dc7cf2b65d1d361b0572d476a207542118c276be1c46561d832c3ff7053affe06e0893f755af1f44d0a461c98980e9485363f827112b6b WHIRLPOOL 43d833296e5f750bf8e326dea76bfcee4947fe84eb5d0a1da6af160240da94354daf6b8b2f4d5eeb6dc5fcf7735c839e63a2e4844e07c56316e92279796fd0d0
DIST libvirt-python-2.5.0.tar.gz 172329 SHA256 f4fd787ad26b4cd4b32afa65b6248c344ef48edffeb42c892c7adb4866f656d1 SHA512 2ff94ff12c20d9d0e5be8b571bc33fb1641e9940c6b49cdee37244c941674b12e1c980f9e0c73f4db52c91579ab19f92cea0c2e79a97abc67ee3309028661bb6 WHIRLPOOL 78712a122edfd4ce32e73332c8311e6b661be843f10ab30d3d85d426a266ddddbe36d30bfc09e63016189b8ffffe729119884d0d4acb05844b2bef37f8fadd63
+DIST libvirt-python-3.0.0.tar.gz 174075 SHA256 94a7c1c57a643afad43f9068c70774e1146ed051ecfca0280d5127011c5e44c1 SHA512 8bdc98817703cca0369d2d3335bfb1aed4f42b292d074995b80fc590bb1d04032130acd7ea3a750639a5c68c5208f7c2bd082bddaa74163f2015cc041e3d2ef8 WHIRLPOOL 17b54961770202e0aabf965f3686594b96cbc5a1cdbae1ae332c19af89f2b0ee630b39f0fd5740c14a38bc2166d2f4f44bc448e07b89882b62c180d453d3352c
diff --git a/dev-python/libvirt-python/libvirt-python-3.0.0.ebuild b/dev-python/libvirt-python/libvirt-python-3.0.0.ebuild
new file mode 100644
index 000000000000..aa41d175a769
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-3.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}