summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-18 10:00:52 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-18 10:51:33 +0100
commitc0ea49679d3d8273d3f2b5ccd5937100860f8cad (patch)
tree2b79238bb03a4f5363d417b89c832009847e2385 /dev-python
parentdev-python/cli_helpers: Bump to 2.2.1 (diff)
downloadgentoo-c0ea49679d3d8273d3f2b5ccd5937100860f8cad.tar.gz
gentoo-c0ea49679d3d8273d3f2b5ccd5937100860f8cad.tar.bz2
gentoo-c0ea49679d3d8273d3f2b5ccd5937100860f8cad.zip
dev-python/precis-i18n: Bump to 1.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/precis-i18n/Manifest1
-rw-r--r--dev-python/precis-i18n/precis-i18n-1.0.4.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/precis-i18n/Manifest b/dev-python/precis-i18n/Manifest
index f2c38c87ea2b..0d6fa4c67345 100644
--- a/dev-python/precis-i18n/Manifest
+++ b/dev-python/precis-i18n/Manifest
@@ -1 +1,2 @@
DIST precis_i18n-1.0.3.tar.gz 64037 BLAKE2B 99486f8791785ecad7f3a246a0a13f26ec52aa91bc40ac904e92409f2cdbb28a5458c153da593ca8dd626462f0216e8c72447fdc81f8133ed61240717d08cbf7 SHA512 afb987fe4d0fb2732c62585e70361ad5ffc14d1eb9b8e767fe314fa9a3dee8dcd14f2531f5638d3a72fa7ac4fbeed94ed8907976816570257b405468cdb6702a
+DIST precis_i18n-1.0.4.tar.gz 67599 BLAKE2B db1f614b46015741b9f511b9a5df12e44b960ffb247357bf8d2e9f3a1deea9d417eed937e6c9e6a34d19a22c3e6d87bf8f2314767cd02b15cba068759588896f SHA512 f57840cffe1224d282e707f6a36ebd53b539f9acee58de7053f28ceed5356bd35627d7c205cc91dc81983925cca55138715051c0ca535ca1dcc9d26aad9a9353
diff --git a/dev-python/precis-i18n/precis-i18n-1.0.4.ebuild b/dev-python/precis-i18n/precis-i18n-1.0.4.ebuild
new file mode 100644
index 000000000000..68dc8485e8b5
--- /dev/null
+++ b/dev-python/precis-i18n/precis-i18n-1.0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Internationalized Usernames and Passwords"
+HOMEPAGE="https://pypi.org/project/precis-i18n/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s test
+}