summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-17 18:45:51 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-17 18:48:28 +0200
commitc3617f0ef2619038d485f0c2de3c9b0264e01c37 (patch)
tree38cf7891f7f39c39e15d97ce2f4b9f5d998b99d7 /dev-python
parentdev-python/bibtexparser: mark ALLARCHES (diff)
downloadgentoo-c3617f0ef2619038d485f0c2de3c9b0264e01c37.tar.gz
gentoo-c3617f0ef2619038d485f0c2de3c9b0264e01c37.tar.bz2
gentoo-c3617f0ef2619038d485f0c2de3c9b0264e01c37.zip
dev-python/pytest-httpx: add 0.18.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.18.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index ec507f012f65..c679b3bd6362 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -2,3 +2,4 @@ DIST pytest-httpx-0.13.0.tar.gz 21515 BLAKE2B 691ce45dd2b27c8f47724e3356ba96e62a
DIST pytest-httpx-0.17.1.tar.gz 23310 BLAKE2B 3b26a50380916a556657a02bc4d44ceb523261f14404eaf3461dae8adb99e913e820c55942bc200b6d23f85447bf74e37c8cbfea2c934489e5d91a56f47b186a SHA512 8fa9447bf50f9bf46ad781abbf9e5d46609e2796a6ec26d39b15c1cda99fc936af6b540c27f9cbe4f40948f041ceedd074c312815fe5ea6b023da20112c83f69
DIST pytest-httpx-0.17.2.tar.gz 23385 BLAKE2B 17a00a7c733bca7faf8e05914c0744288fe8555bc9d8f94d45ce0162b86417fcf608d339d9d4a24514e2897db879a6d13c41f665a8cf5d3c1ac1769c246a582e SHA512 aaeded94d204d53bf96f802668449361c291d4b0accbe614d8c80d609482f6b10945afb255b81d4199187f3c50cb98d35d5acfd75423283907223ca924b85444
DIST pytest-httpx-0.17.3.tar.gz 23737 BLAKE2B 1f335542c1d6940d68b023682df6a1fabe93e8e21b70e113830bc4895481fe1cbf074490b176ecd91f595df960790f7e305c3809af3ba5039b96c8748b40ee40 SHA512 b3c2dc8c5015f44a511659b51843cb9cf8ada163ebd7fe4ccb50438d6e191fdc84bb84f38fcd0c27dbfe0592314da0df8d319caecad32f37e3a30de40b496299
+DIST pytest-httpx-0.18.0.gh.tar.gz 22939 BLAKE2B a55923e63ad47ebd6ef05eafdadcec4caabab1341ab5f70e68357bc44cab53006a38b0d07f9540007ac46686499fd7355610a22a82b075a1e674d1fa3250efe9 SHA512 a7f24eefb8ba371e8c86526dd63e5ec7a6fa2e7a122643c8907a3da3b9a17a06e99416c5dc927f42320aa88fc213d5a327f53ec92e345853d5350902801fa1bc
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.18.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.18.0.ebuild
new file mode 100644
index 000000000000..46d0ac881491
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.18.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="https://colin-b.github.io/pytest_httpx/"
+SRC_URI="
+ https://github.com/Colin-b/${MY_PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.21*[${PYTHON_USEDEP}]
+ =dev-python/pytest-6*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest