summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-02-26 12:33:18 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-02-26 12:33:18 +0100
commitc4d4b70354d9ecf14ba825a6d6d37a3794c16768 (patch)
treec0520353b0f727f4c13a78eb7c51fd945c6d934a /dev-python
parentsys-apps/habitat: Version bump to 0.54.0 (diff)
downloadgentoo-c4d4b70354d9ecf14ba825a6d6d37a3794c16768.tar.gz
gentoo-c4d4b70354d9ecf14ba825a6d6d37a3794c16768.tar.bz2
gentoo-c4d4b70354d9ecf14ba825a6d6d37a3794c16768.zip
dev-python/pylint: Version bump to 1.7.5
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-1.7.5.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index c8b1726a13f0..c753ea8c3114 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,2 +1,3 @@
DIST pylint-1.6.5.tar.gz 465578 BLAKE2B 05412a528878633ef7529dd2f2d2d1989bc9406666626d62764f476bbc024e34fea06883fae829fe6617ebfffde54dfa5600c140b9a25e6c9633f48d76f5c331 SHA512 2fac352dc752b37f1ce4f7fefe5afbbc880d7e6c38f164d1c50734716af1dd6fe31f7d41e145a8256837d5a63b1989efec40c169fc14840cf8eb4e18d9bb2410
DIST pylint-1.7.2.tar.gz 488628 BLAKE2B 6f2902bdd18939f251515d652d2e9df43162c1b0c27c2e2ed7392ee77be9e7f81bbd62cede4f2eb1e7aa646bf47c48b01436e04cbf46a20458a1c89eff752d9d SHA512 268f141f017fa4df6024596bcf1dfb32a578e9459864e2ace8c2725c8f5e117e0b01d9d745f1632bb43102a01f7075dc3fb69b839b79371f7df47740a56fc1cb
+DIST pylint-1.7.5.tar.gz 486892 BLAKE2B 0a415045e16aeb6e8543af003cff3061756b01bcbeb9f62de7cf1a63356ff01c3a2fd079e51ee0f8b1b797dd3de29c14d9928c0b4d0214fda82fbc2dc12010c6 SHA512 9f28cc4f88b26d2299ab3ea015935fba8c96f700c7898ad8fbdecfa0902f10a4ca54ad346b18452f8a589f8b63494bc12487dab36d168f336012b259bfa6f3f8
diff --git a/dev-python/pylint/pylint-1.7.5.ebuild b/dev-python/pylint/pylint-1.7.5.ebuild
new file mode 100644
index 000000000000..3bf9b99e1a37
--- /dev/null
+++ b/dev-python/pylint/pylint-1.7.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="http://www.logilab.org/project/pylint
+ https://pypi.python.org/pypi/pylint
+ https://github.com/pycqa/pylint"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/astroid-1.5.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ dev-python/mccabe[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]
+ dev-python/configparser[${PYTHON_USEDEP}]' -2)"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ <dev-python/pytest-3.3[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # remove unused dep
+ sed -i -e '/pytest-runner/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # selection of straight html triggers a trivial annoying bug, we skirt it
+ use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml
+}
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ doman man/{pylint,pyreverse}.1
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+ use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." 'dev-lang/python[tk]'
+}