summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-03-03 10:27:33 +0100
committerMichał Górny <mgorny@gentoo.org>2016-03-03 11:47:37 +0100
commitc5967f52754515991653499d1615d6e132e5d52b (patch)
treee28747064ab04b4df7852442c7f33cb4bce213b0 /dev-python
parentdev-python/pypy-bin: Add RDEPs to DEPEND, and subslots everywhere (diff)
downloadgentoo-c5967f52754515991653499d1615d6e132e5d52b.tar.gz
gentoo-c5967f52754515991653499d1615d6e132e5d52b.tar.bz2
gentoo-c5967f52754515991653499d1615d6e132e5d52b.zip
dev-python/pypy3-bin: Add RDEPs to DEPEND, and subslots everywhere
Add RDEPENDs to DEPEND since we run the built PyPy in order to generate CFFI caches and byte-compile modules. Fixes: https://bugs.gentoo.org/576210
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypy3-bin/pypy3-bin-2.4.0-r4.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/dev-python/pypy3-bin/pypy3-bin-2.4.0-r4.ebuild b/dev-python/pypy3-bin/pypy3-bin-2.4.0-r4.ebuild
index a4fa61436e2c..2a4fa3ea87f5 100644
--- a/dev-python/pypy3-bin/pypy3-bin-2.4.0-r4.ebuild
+++ b/dev-python/pypy3-bin/pypy3-bin-2.4.0-r4.ebuild
@@ -54,13 +54,13 @@ IUSE="gdbm +jit +shadowstack sqlite cpu_flags_x86_sse2 test tk"
# yep, world would be easier if people started filling subslots...
RDEPEND="
- app-arch/bzip2:0
- dev-libs/expat:0
- dev-libs/libffi:0
- dev-libs/openssl:0
- sys-libs/glibc:2.2
+ app-arch/bzip2:0=
+ dev-libs/expat:0=
+ dev-libs/libffi:0=
+ dev-libs/openssl:0=
+ sys-libs/glibc:2.2=
sys-libs/ncurses:0/6
- sys-libs/zlib:0
+ sys-libs/zlib:0=
gdbm? ( sys-libs/gdbm:0= )
sqlite? ( dev-db/sqlite:3= )
tk? (
@@ -68,9 +68,9 @@ RDEPEND="
dev-tcltk/tix:0=
)
!dev-python/pypy3:0"
-DEPEND="app-arch/lzip
- test? ( ${RDEPEND}
- ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ app-arch/lzip
+ test? ( ${PYTHON_DEPS} )"
# doc? ( ${PYTHON_DEPS}
# dev-python/sphinx )
PDEPEND="app-admin/python-updater"