summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2019-03-03 20:41:50 -0500
committerPatrice Clement <monsieurp@gentoo.org>2019-03-10 23:35:06 +0100
commitcba9ea6f878c535752351466e2e64119b9f30f9a (patch)
tree54c4ac0b081ae4cef0750ae824c2f4c1dc8c161c /dev-python
parentmedia-video/mpv: add youtube-dl pkg_postinst message. (diff)
downloadgentoo-cba9ea6f878c535752351466e2e64119b9f30f9a.tar.gz
gentoo-cba9ea6f878c535752351466e2e64119b9f30f9a.tar.bz2
gentoo-cba9ea6f878c535752351466e2e64119b9f30f9a.zip
dev-python/neovim-python-client: version bump to 0.3.2.
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Closes: https://github.com/gentoo/gentoo/pull/11248 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/neovim-python-client/Manifest1
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.3.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/neovim-python-client/Manifest b/dev-python/neovim-python-client/Manifest
index 20598bf50acc..f717eecd750e 100644
--- a/dev-python/neovim-python-client/Manifest
+++ b/dev-python/neovim-python-client/Manifest
@@ -1,2 +1,3 @@
DIST neovim-python-client-0.2.6.tar.gz 50170 BLAKE2B d241ae0019bb8a4f08abf11866d7c964425d96756452e7bafb95fbce1795657c6911cf6bb706f5efa46ac3f5bd2c4af23ade9b9677d8f1f94905d72a39ddfde5 SHA512 a493c1e6be6a196d35e69e6b6b6a7752e939a254ed423079468c0e13ce40c2646ee8d65482648ea37a9d9c53b4f2c50cdd5e6c8dc130e63a7e40f424c4f4a9c0
DIST neovim-python-client-0.3.1.tar.gz 51626 BLAKE2B 80e68d02d41c7891fb88e9386866f87a1c78acc9e279de4ce4c7022333f8da3b68ffe7c598c84ff9c6386458639b6ffb4aecbfe72288866dc147ffc6197e94e2 SHA512 9c1599aabce9f0e1133364f8e91dd1b57cee107a11d400f530218ec7ad157c2f58134c1e7e8fc27649b4d8953e27c51bf6e4f0e7565d8c3dab94788759eea229
+DIST neovim-python-client-0.3.2.tar.gz 51954 BLAKE2B 8e0a5eb510797db260ab501b751921f5c98551a06cf874eecff270f5f92da5d24539b857b4cc08494be9dfed139fd3bcab1cdea75ee87d99cece8e1f48f7a1c5 SHA512 c6d7c1a2955c63ac2f59bc57e190886fe0ee0238951ac26205b537d394b2ce2fee3611e8651ae1da5e6e7b3a1bd3bea36912b918b26e01bbb3354ddc2fbd77fc
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.3.2.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.3.2.ebuild
new file mode 100644
index 000000000000..6956edc96bf0
--- /dev/null
+++ b/dev-python/neovim-python-client/neovim-python-client-0.3.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for Neovim"
+HOMEPAGE="https://github.com/neovim/pynvim"
+SRC_URI="https://github.com/neovim/pynvim/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/msgpack-0.5.2[${PYTHON_USEDEP}]
+ virtual/python-greenlet[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)"
+
+RDEPEND="
+ ${DEPEND}
+ >=app-editors/neovim-0.2.1"
+
+S="${WORKDIR}/pynvim-${PV}"
+
+python_prepare_all() {
+ # allow useage of renamed msgpack
+ sed -i '/^msgpack/d' setup.py || die
+ distutils-r1_python_prepare_all
+}