summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-13 10:18:35 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-13 10:19:03 -0700
commitcc89c679a0afdb4379b82cacdfe48f8950f7ea37 (patch)
treeee8588baf47c466ed271a7ed7e1b7878e3d22e35 /dev-python
parentdev-python/zipp: ppc64 stable wrt bug #720662 (diff)
downloadgentoo-cc89c679a0afdb4379b82cacdfe48f8950f7ea37.tar.gz
gentoo-cc89c679a0afdb4379b82cacdfe48f8950f7ea37.tar.bz2
gentoo-cc89c679a0afdb4379b82cacdfe48f8950f7ea37.zip
dev-python/apispec-3.3.0: version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-3.3.0.ebuild33
-rw-r--r--dev-python/apispec/files/apispec-3.3.0-tests.patch20
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index c5f2a6a964b8..ad32036c7ff4 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1 +1,2 @@
DIST apispec-0.35.0.tar.gz 47684 BLAKE2B 3067a0d50a6f53378f46a9a07596da53679f399732619f5bd3d1bedd85d088c6901560dc46be22b42d77537c437d9d97840a55f0b1513e39c87760e9e6c8ea0c SHA512 45a3034c49169ca7998480a8b8e0ac6415d49b6235885fba31eaaccb1c008b4ea845a6743f10cc3492215affe20b690d73a9a06e0e0c3942e0327f381415fa57
+DIST apispec-3.3.0.tar.gz 66952 BLAKE2B a744230a1754d88b3bdc2325916e100d1de19bdf0e7985245d9f0ecf4a6bd9c778e502be73107a90a3676e8ecda45653d9f0962d33f68c6242bc52dc4695b1cb SHA512 f8cfaeec9486554653a09ce37cf2aa11b037047aa3af918a1273a4ca892d723c9367827cb3a034683722965f17dc8ed45ce3f163631c666902a3a87b5485b537
diff --git a/dev-python/apispec/apispec-3.3.0.ebuild b/dev-python/apispec/apispec-3.3.0.ebuild
new file mode 100644
index 000000000000..df2a9b020bce
--- /dev/null
+++ b/dev-python/apispec/apispec-3.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator."
+HOMEPAGE="https://github.com/marshmallow-code/apispec/"
+SRC_URI="https://github.com/marshmallow-code/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/marshmallow[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/apispec-3.3.0-tests.patch"
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/apispec/files/apispec-3.3.0-tests.patch b/dev-python/apispec/files/apispec-3.3.0-tests.patch
new file mode 100644
index 000000000000..fb2ffc549207
--- /dev/null
+++ b/dev-python/apispec/files/apispec-3.3.0-tests.patch
@@ -0,0 +1,20 @@
+diff --git a/tests/test_ext_marshmallow_openapi.py b/tests/test_ext_marshmallow_openapi.py
+index ab1b0b8..d151a32 100644
+--- a/tests/test_ext_marshmallow_openapi.py
++++ b/tests/test_ext_marshmallow_openapi.py
+@@ -454,6 +454,7 @@ class TestNesting:
+ assert "breed" not in category_props
+
+
++@pytest.mark.skip("test requires extra dependencies")
+ def test_openapi_tools_validate_v2():
+ ma_plugin = MarshmallowPlugin()
+ spec = APISpec(
+@@ -512,6 +513,7 @@ def test_openapi_tools_validate_v2():
+ pytest.fail(str(error))
+
+
++@pytest.mark.skip("test requires extra dependencies")
+ def test_openapi_tools_validate_v3():
+ ma_plugin = MarshmallowPlugin()
+ spec = APISpec(