summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-05-14 11:00:14 +0200
committerMichał Górny <mgorny@gentoo.org>2016-05-14 11:06:49 +0200
commitcf1a2d5bade3d0e860d3188e179d72df682c861e (patch)
tree2351411901d8cb441c1e2d1d1b0bc73e673dfdaf /dev-python
parentdev-python/pypy: Fix pax-marking in src_compile() (diff)
downloadgentoo-cf1a2d5bade3d0e860d3188e179d72df682c861e.tar.gz
gentoo-cf1a2d5bade3d0e860d3188e179d72df682c861e.tar.bz2
gentoo-cf1a2d5bade3d0e860d3188e179d72df682c861e.zip
dev-python/pypy3: Fix pax-marking in src_compile()
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypy3/pypy3-2.4.0-r2.ebuild4
-rw-r--r--dev-python/pypy3/pypy3-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/pypy3/pypy3-2.4.0-r2.ebuild b/dev-python/pypy3/pypy3-2.4.0-r2.ebuild
index 07646dbe336f..3ff589490315 100644
--- a/dev-python/pypy3/pypy3-2.4.0-r2.ebuild
+++ b/dev-python/pypy3/pypy3-2.4.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -162,7 +162,7 @@ src_compile() {
# assert txt.check()
# AssertionError
#use doc && emake -C pypy/doc/ html
- pax-mark m "${ED%/}${INSDESTTREE}/pypy-c"
+ pax-mark m pypy-c libpypy-c.so
}
src_test() {
diff --git a/dev-python/pypy3/pypy3-9999.ebuild b/dev-python/pypy3/pypy3-9999.ebuild
index 5f1b62c15d96..c00fc6575e06 100644
--- a/dev-python/pypy3/pypy3-9999.ebuild
+++ b/dev-python/pypy3/pypy3-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -160,7 +160,7 @@ src_compile() {
"${@}" || die "compile error"
#use doc && emake -C pypy/doc/ html
- pax-mark m "${ED%/}${INSDESTTREE}/pypy-c"
+ pax-mark m pypy-c libpypy-c.so
}
src_install() {