summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-09-27 18:02:01 +0200
committerHanno Böck <hanno@gentoo.org>2020-09-27 18:02:01 +0200
commitcf27d3e11936edaf00cc227ace38758b98a27e86 (patch)
tree2a12d7886464d9420396d1fd9f96b3dc2181a24d /dev-python
parentdev-util/gtk-builder-convert: add Python 3 patch (diff)
downloadgentoo-cf27d3e11936edaf00cc227ace38758b98a27e86.tar.gz
gentoo-cf27d3e11936edaf00cc227ace38758b98a27e86.tar.bz2
gentoo-cf27d3e11936edaf00cc227ace38758b98a27e86.zip
dev-python/flufl-lock: Bump and python 3.8
Patch upstream bug that installs docs/tests into global namespace. Closes: https://bugs.gentoo.org/743923 Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flufl-lock/Manifest1
-rw-r--r--dev-python/flufl-lock/files/flufl-lock-dontinstalltests.diff12
-rw-r--r--dev-python/flufl-lock/flufl-lock-5.0.1.ebuild29
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/flufl-lock/Manifest b/dev-python/flufl-lock/Manifest
index bd3d93f7f12d..fe5c14b99c34 100644
--- a/dev-python/flufl-lock/Manifest
+++ b/dev-python/flufl-lock/Manifest
@@ -1 +1,2 @@
DIST flufl-lock-3.2.tar.gz 19250 BLAKE2B 230d7122fb6db1b4002e5732a878d597837f1c8cb10b85f4c131f793f820dc0b76a494504aef89845be4f7bdfab94b17573f83002712c245206c9ce25fac893a SHA512 496195e1c52f628bc6c0e8fc3dcd5373ed01cfee35b6165cae37ab4b90d70265c6a0aea565f1e0663277c2b9e9bafde8af1420133a15e6254275fad2f28a56d0
+DIST flufl-lock-5.0.1.tar.gz 27788 BLAKE2B 2651898e881719f24bc61e14f697877ca39f2747fadf52de1a5fc917b26e23001df5f0a4ea2e48271da69198e1a1336e69cc0167a4f46fddd21f464b355fa4ca SHA512 f937fb6c7f7bef2b85674225f83f3162f34db3fe2df3d9a896f772c4489c3e0611361e3d1d9efda7727112d780f31022d3045d3a3b8e78e9412aca2f2418ca24
diff --git a/dev-python/flufl-lock/files/flufl-lock-dontinstalltests.diff b/dev-python/flufl-lock/files/flufl-lock-dontinstalltests.diff
new file mode 100644
index 000000000000..3cd5bfba99ed
--- /dev/null
+++ b/dev-python/flufl-lock/files/flufl-lock-dontinstalltests.diff
@@ -0,0 +1,12 @@
+diff -Naurp a/setup.py b/setup.py
+--- a/setup.py 2020-08-20 06:35:06.000000000 +0200
++++ b/setup.py 2020-09-27 17:50:43.776476265 +0200
+@@ -24,7 +24,7 @@ setup(
+ keywords='locking locks lock',
+ url='https://flufllock.readthedocs.io',
+ download_url='https://pypi.python.org/pypi/flufl.lock',
+- packages=find_namespace_packages(where='.'),
++ packages=find_namespace_packages(where='.', exclude=['tests', 'docs']),
+ namespace_packages=['flufl'],
+ include_package_data=True,
+ # readthedocs builds fail unless zip_safe is False.
diff --git a/dev-python/flufl-lock/flufl-lock-5.0.1.ebuild b/dev-python/flufl-lock/flufl-lock-5.0.1.ebuild
new file mode 100644
index 000000000000..29e78cd92cc3
--- /dev/null
+++ b/dev-python/flufl-lock/flufl-lock-5.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="NFS-safe file locking with timeouts for POSIX systems."
+HOMEPAGE="https://gitlab.com/warsaw/flufl.lock"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' python3_{6,7})"
+
+# See https://gitlab.com/warsaw/flufl.lock/-/issues/22
+PATCHES=( "${FILESDIR}/flufl-lock-dontinstalltests.diff" )