summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-07 15:28:12 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-07 15:30:10 +0200
commitd3e1ccd13c9e964f1393446b4e0dc0a68ef433e6 (patch)
tree8f5a01defe9046e52484860ef254e3678bd7f052 /dev-python
parentdev-libs/libevent: Use HTTPS in HOMEPAGE (diff)
downloadgentoo-d3e1ccd13c9e964f1393446b4e0dc0a68ef433e6.tar.gz
gentoo-d3e1ccd13c9e964f1393446b4e0dc0a68ef433e6.tar.bz2
gentoo-d3e1ccd13c9e964f1393446b4e0dc0a68ef433e6.zip
dev-python/pgspecial: Add tests, fix deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pgspecial/pgspecial-1.11.5.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/dev-python/pgspecial/pgspecial-1.11.5.ebuild b/dev-python/pgspecial/pgspecial-1.11.5.ebuild
index edaec9de0592..4cd33f7650ef 100644
--- a/dev-python/pgspecial/pgspecial-1.11.5.ebuild
+++ b/dev-python/pgspecial/pgspecial-1.11.5.ebuild
@@ -13,9 +13,22 @@ SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
>=dev-python/python-sqlparse-0.1.19[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ # tests/test_special.py require local postgres instance
+ pytest -vv tests/test_internal.py || die
+}