summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-11 16:14:47 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-11 16:26:26 +0100
commitd47dae5503def17a99e7bef777a3b4fceeaf5fe6 (patch)
treeccd38dbac521e288ebb0665dacdd2dbdcb7e5aee /dev-python
parentdev-ros/rosbash: add rospack dep (diff)
downloadgentoo-d47dae5503def17a99e7bef777a3b4fceeaf5fe6.tar.gz
gentoo-d47dae5503def17a99e7bef777a3b4fceeaf5fe6.tar.bz2
gentoo-d47dae5503def17a99e7bef777a3b4fceeaf5fe6.zip
dev-python/rosdistro: disable tests requiring network access
Closes: https://bugs.gentoo.org/643458 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rosdistro/rosdistro-0.8.0.ebuild6
-rw-r--r--dev-python/rosdistro/rosdistro-9999.ebuild7
2 files changed, 13 insertions, 0 deletions
diff --git a/dev-python/rosdistro/rosdistro-0.8.0.ebuild b/dev-python/rosdistro/rosdistro-0.8.0.ebuild
index 5b587a80181e..cf60a935e58c 100644
--- a/dev-python/rosdistro/rosdistro-0.8.0.ebuild
+++ b/dev-python/rosdistro/rosdistro-0.8.0.ebuild
@@ -43,6 +43,12 @@ DEPEND="${RDEPEND}
"
PATCHES=( "${FILESDIR}/yaml.patch" )
+src_prepare() {
+ # Requires network access
+ rm -f test/test_manifest_providers.py
+ default
+}
+
python_test() {
nosetests --with-xunit test || die
}
diff --git a/dev-python/rosdistro/rosdistro-9999.ebuild b/dev-python/rosdistro/rosdistro-9999.ebuild
index 1cf2e00b257c..cf60a935e58c 100644
--- a/dev-python/rosdistro/rosdistro-9999.ebuild
+++ b/dev-python/rosdistro/rosdistro-9999.ebuild
@@ -41,6 +41,13 @@ DEPEND="${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
)
"
+PATCHES=( "${FILESDIR}/yaml.patch" )
+
+src_prepare() {
+ # Requires network access
+ rm -f test/test_manifest_providers.py
+ default
+}
python_test() {
nosetests --with-xunit test || die