summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-20 06:23:54 +0000
committerSam James <sam@gentoo.org>2020-12-20 06:23:54 +0000
commitd4b5d31267739fabcb79c3ceab397440c0a12cbb (patch)
tree760220ed4623db5960178a9742f0108856db19e1 /dev-python
parentdev-libs/botan: cleanup old (diff)
downloadgentoo-d4b5d31267739fabcb79c3ceab397440c0a12cbb.tar.gz
gentoo-d4b5d31267739fabcb79c3ceab397440c0a12cbb.tar.bz2
gentoo-d4b5d31267739fabcb79c3ceab397440c0a12cbb.zip
dev-python/redis-py: cleanup old
Package-Manager: Portage-3.0.12-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/redis-py/Manifest1
-rw-r--r--dev-python/redis-py/redis-py-3.3.11.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/redis-py/Manifest b/dev-python/redis-py/Manifest
index d371b403131f..fb2f7d6f986a 100644
--- a/dev-python/redis-py/Manifest
+++ b/dev-python/redis-py/Manifest
@@ -1,2 +1 @@
-DIST redis-py-3.3.11.tar.gz 131072 BLAKE2B 6becafba3da22bae796a4a9ba55d11a61d9ed1a8b693a734d4ef3f0e463c0c39a05c01546225f69eb36a788779d6e45d0136e1a6d6856ec63c3dd07994b5db9a SHA512 a32327fcebc6242367c0eda6c6dcd1a15d5d575527af2e9de0d76e05bc4afc7402566d9254e467663b81907a310731af3041236b6b135f3b8ff1429a502c1000
DIST redis-py-3.5.3.tar.gz 141112 BLAKE2B b953d553a3cfa2d6ba6f5aa35dfaf93865acbfad0e901a96082c3b1c027dc23b6ceedde185f24e86772522fbbf4f0a4d18e115a6b40aff6a65450bbe397d5c07 SHA512 eae6ac6b3e0f1366a9c29e5e2d9a5210e4627e62e3006159b1c290f36cd9c1c2c12cafe0944f7a010e04632b517874f230aa9411491993b7ecf2080546217206
diff --git a/dev-python/redis-py/redis-py-3.3.11.ebuild b/dev-python/redis-py/redis-py-3.3.11.ebuild
deleted file mode 100644
index ef36d2f03060..000000000000
--- a/dev-python/redis-py/redis-py-3.3.11.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-MY_PN="redis"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python client for Redis key-value store"
-HOMEPAGE="https://github.com/andymccurdy/redis-py"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="test? (
- dev-db/redis
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.7.0[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- # Make sure that tests will be used from BUILD_DIR rather than cwd.
- mv tests tests-hidden || die
-
- # Correct local import patch syntax
- sed \
- -e 's:from .conftest:from conftest:' \
- -e 's:from .test_pubsub:from test_pubsub:' \
- -i tests-hidden/test_*.py \
- || die
-}
-
-python_compile() {
- distutils-r1_python_compile
-
- if use test; then
- cp -r tests-hidden "${BUILD_DIR}"/tests || die
- fi
-}
-
-python_test() {
- local sock="${T}/redis.sock"
-
- "${EPREFIX}/usr/sbin/redis-server" - <<- EOF
- daemonize yes
- pidfile "${T}/redis.pid"
- unixsocket ${sock}
- EOF
-
- PYTHONPATH="${S}:${S}/tests-hidden"
- esetup.py test --verbose
- kill $(<"${T}/redis.pid")
-}