summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-29 18:54:00 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-12-29 19:56:02 +0000
commitd5aa6c1660c8bfe005f56074e4372307cbdc7a9e (patch)
tree80e738ffc99046a0d8ad7eafd2f82e86b3edcbe6 /dev-python
parentdev-python/jplephem: initial import (diff)
downloadgentoo-d5aa6c1660c8bfe005f56074e4372307cbdc7a9e.tar.gz
gentoo-d5aa6c1660c8bfe005f56074e4372307cbdc7a9e.tar.bz2
gentoo-d5aa6c1660c8bfe005f56074e4372307cbdc7a9e.zip
dev-python/sphinx-gallery: initial import
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx-gallery/Manifest1
-rw-r--r--dev-python/sphinx-gallery/metadata.xml12
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.1.7.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
new file mode 100644
index 000000000000..34987bf4ccc0
--- /dev/null
+++ b/dev-python/sphinx-gallery/Manifest
@@ -0,0 +1 @@
+DIST sphinx-gallery-0.1.7.tar.gz 59166 SHA256 594da5b4ed08e6531798c735608f4fe65a8bd394ea3b7b9194d9e659e48a4ea0 SHA512 0c14d35ed07db3988c9f119037676752e3f793a74000d7397f49e5b749a96db77ff4ba2e9ceb12993650e0c81042899a5056f3181e5360a738a5c62259c58ff5 WHIRLPOOL a307ddb0e4b0844ec823399fd8d00ea7fb7aa55cf243c63d7d6ad151cf3285c1f48eebb7f8e8f78b329688e9c73b54b5be0c14fe1ce264896f50af4dddd9d7b7
diff --git a/dev-python/sphinx-gallery/metadata.xml b/dev-python/sphinx-gallery/metadata.xml
new file mode 100644
index 000000000000..d2a56513871a
--- /dev/null
+++ b/dev-python/sphinx-gallery/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinx-gallery</remote-id>
+ <remote-id type="github">sphinx-gallery/sphinx-gallery</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.1.7.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.1.7.ebuild
new file mode 100644
index 000000000000..a1f4cb520d93
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.1.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="http://sphinx-gallery.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"