summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2020-03-11 16:33:43 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-03-11 16:56:15 -0500
commitd5ffac9c5150984895f6d1f7e6379f289d40fa11 (patch)
treec12814a6d058dd3b4955e20ec71af1c688dd641f /dev-python
parentdev-python/django-mptt: 0.11.0 bump (diff)
downloadgentoo-d5ffac9c5150984895f6d1f7e6379f289d40fa11.tar.gz
gentoo-d5ffac9c5150984895f6d1f7e6379f289d40fa11.tar.bz2
gentoo-d5ffac9c5150984895f6d1f7e6379f289d40fa11.zip
dev-python/django-prometheus: 2.0.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-prometheus/Manifest1
-rw-r--r--dev-python/django-prometheus/django-prometheus-2.0.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/django-prometheus/Manifest b/dev-python/django-prometheus/Manifest
index 0a58d0241892..bfca67e3f6ba 100644
--- a/dev-python/django-prometheus/Manifest
+++ b/dev-python/django-prometheus/Manifest
@@ -1,2 +1,3 @@
DIST django-prometheus-1.0.15.tar.gz 13708 BLAKE2B 64d72224da9cb481108ad17ed1409d97108353a39894f824428743f3ee894292352de4d4beebf1984294e34cea7b6d0144c5066d0fe5cca7d9c682f9410355d3 SHA512 48794f6d07ebdd3487060e62e808a66a97630045433dd91a27f1095f79a72197124c44c5d178c89785b8d048e8e828f84804c789cb5c2f0a053cf18864cde6eb
DIST django-prometheus-1.1.0.tar.gz 18237 BLAKE2B 9b32e95750b57122a42d2e0b7f257407885a08db446e013933d2e81a525bf99f872f82c7f081f4c8c3c18f899c48ffa947ac8a89b751babaa8a8348f3f50b757 SHA512 9fa8c0175d1f8f714954f1c16715007e5c074568cc703d57e62f24686db1e16c40fc02244c4f9721995636723d90435bb3b2348282530d969b543bce39e65774
+DIST django-prometheus-2.0.0.tar.gz 20028 BLAKE2B 272f192cc0ee4492fa6dbbb65ba6696fdf8fbddc0724290d9b55e5aedb740c2c92cb609969240004b4faca4569580ab451284c2f4bbde589ee61bb96ec448ff3 SHA512 8345c23c8032f0dbecd8e801bd6673e7e3804003ebee0a15b0c8ce3b2d4c6b6f47e7c41e33df2b18a0497eb453972d8b231b88fb51184fafc58d306a9430fdec
diff --git a/dev-python/django-prometheus/django-prometheus-2.0.0.ebuild b/dev-python/django-prometheus/django-prometheus-2.0.0.ebuild
new file mode 100644
index 000000000000..a745970dbcd7
--- /dev/null
+++ b/dev-python/django-prometheus/django-prometheus-2.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="Library to export django metrics for prometheus"
+HOMEPAGE="https://github.com/korfuri/django-prometheus"
+SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
+
+LICENSE="Apache-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-python/prometheus_client-0.7[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ sed -i "s/'pytest-runner'//" setup.py || die
+ distutils-r1_python_prepare_all
+}