summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2018-06-29 08:09:10 -0400
committerMichael Orlitzky <mjo@gentoo.org>2018-06-29 08:09:10 -0400
commitd77406d8be24779b98b1eed7f1aab9e8e0585c91 (patch)
tree94fdcba4e769fd57aec0e17ea52f713aa80de6e6 /dev-python
parentdev-python/pyzor: stabilize 1.0.0-r1 on ppc64 (ALLARCHES). (diff)
downloadgentoo-d77406d8be24779b98b1eed7f1aab9e8e0585c91.tar.gz
gentoo-d77406d8be24779b98b1eed7f1aab9e8e0585c91.tar.bz2
gentoo-d77406d8be24779b98b1eed7f1aab9e8e0585c91.zip
dev-python/pyzor: remove old pyzor-1.0.0.ebuild.
Closes: https://bugs.gentoo.org/643692 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyzor/pyzor-1.0.0.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/pyzor/pyzor-1.0.0.ebuild b/dev-python/pyzor/pyzor-1.0.0.ebuild
deleted file mode 100644
index 8a7979939342..000000000000
--- a/dev-python/pyzor/pyzor-1.0.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-PYHON_REQ_USE="gdbm"
-
-inherit distutils-r1
-
-MY_PV="1-0-0"
-DESCRIPTION="A distributed, collaborative spam detection and filtering network"
-HOMEPAGE="https://github.com/SpamExperts/pyzor/"
-SRC_URI="https://github.com/SpamExperts/${PN}/archive/release-${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-
-IUSE="doc gevent mysql pyzord redis test"
-
-RDEPEND="mysql? ( $(python_gen_cond_dep '>=dev-python/mysql-python-1.2.5[${PYTHON_USEDEP}]' python2_7) )
- redis? ( ~dev-python/redis-py-2.9.1[${PYTHON_USEDEP}] )
- gevent? ( $(python_gen_cond_dep '~dev-python/gevent-1.0.1[${PYTHON_USEDEP}]' python2_7) )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-# https://sourceforge.net/apps/trac/pyzor/attachment/ticket/196/
-DISTUTILS_IN_SOURCE_BUILD=1
-
-REQUIRED_USE="test? ( mysql redis )"
-S="${WORKDIR}/${PN}-release-${MY_PV}"
-
-python_test() {
- # The suite is py2 friendly only
- if ! python_is_python3; then
- PYTHONPATH=. "${PYTHON}" ./tests/unit/__init__.py
- fi
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/.build/html/. )
- distutils-r1_python_install_all
-}
-
-src_install () {
- distutils-r1_src_install
-
- if use pyzord; then
- dodir /usr/sbin
- mv "${D}"usr/bin/pyzord* "${ED}usr/sbin"
- else
- rm "${D}"usr/bin/pyzord*
- fi
-}
-
-pkg_postinst() {
- if use pyzord; then
- ewarn "/usr/bin/pyzord has been moved to /usr/sbin"
- fi
-
- einfo "If you want to run the pyzor server you will need to emerge / re-emerge"
- einfo "with use flag mysql and or redis. Without either flag provides only the pyzor client"
-}