summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-26 12:16:39 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-26 12:27:15 +0100
commitd89c35874ec376b1554f72fc7c46dbc7d9e2fe21 (patch)
tree6ad749d237a473f2dde32d5f6033c010e43b5671 /dev-python
parentdev-dotnet/pe-format: Remove outdated blocker (diff)
downloadgentoo-d89c35874ec376b1554f72fc7c46dbc7d9e2fe21.tar.gz
gentoo-d89c35874ec376b1554f72fc7c46dbc7d9e2fe21.tar.bz2
gentoo-d89c35874ec376b1554f72fc7c46dbc7d9e2fe21.zip
dev-python/PyGithub: Remove redundant version
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyGithub/Manifest1
-rw-r--r--dev-python/PyGithub/PyGithub-1.44.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/PyGithub/Manifest b/dev-python/PyGithub/Manifest
index 1aa7e6667373..8e90962b132d 100644
--- a/dev-python/PyGithub/Manifest
+++ b/dev-python/PyGithub/Manifest
@@ -1,3 +1,2 @@
DIST PyGithub-1.43.8.gh.tar.gz 2842219 BLAKE2B 7711885beb4cb855ea5a5755abe881f7ae7825feb76cb0ab30aa9ba4a2530440d2816439c43da23a42f134286fa0806875d075920776960f04cdd21131bcf700 SHA512 dc58166ebb27f855ed4f32448029abe7e53b8050d8d99029d460f2dd94180ca8bcef68a75469293abd021f70cc3c67c32061e6439db1b3f1dc77af464c658bb6
DIST PyGithub-1.44.1.gh.tar.gz 2866013 BLAKE2B 90ca7f21fe0031c6cc6d50f54facd7c086037f942f9595e78a3b1a0fe0d21b6bc587f07b63152afabbaa2f38d165b8014600cb195207519a16e3e05fb9bfbcff SHA512 87b6c05f3bbfa463995b67d0bb257700e8c67050dd291c60737a84c4e8bc6bcbde1c0e2add98ec38174c55f2c21abcf4c46bba8be752d132d7e63e423ab6fd1e
-DIST PyGithub-1.44.gh.tar.gz 2855748 BLAKE2B f728562617632f99d5b8a141e7b8eb7527812388e71c7f6dcc55fbec2b0da5ab3882985d4e815fe18affa662351942ba2223eda3ae68bc1cf550c2cbc2bee7f9 SHA512 26aa86822fb8c3ca8a8a0e8d5cd9bf9457cab8a4aa006fa195bb4922867627b5516adbee19cbf5c30d24de8266b496741ae7f4dd8c7cc0494044e6cd585402b1
diff --git a/dev-python/PyGithub/PyGithub-1.44.ebuild b/dev-python/PyGithub/PyGithub-1.44.ebuild
deleted file mode 100644
index 48417603a98e..000000000000
--- a/dev-python/PyGithub/PyGithub-1.44.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library to access the Github API v3"
-HOMEPAGE="https://github.com/PyGithub/PyGithub/"
-# Use github since pypi is missing test data
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/deprecated[${PYTHON_USEDEP}]
- dev-python/pyjwt[${PYTHON_USEDEP}]
- >=dev-python/requests-2.14.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/httpretty-0.9.6[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # tests requiring network access
- sed -i -e 's:testDecodeJson:_&:' tests/Issue142.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${EPYTHON}" -m unittest -v tests.AllTests || die "Tests fail with ${EPYTHON}"
-}