summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-01-10 13:01:20 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-10 13:03:59 +0200
commitd8de8c649c8107cd54dd6edc08558fe9ec68b02a (patch)
treefd3f7614501db0df850562adc374b1c472b5666d /dev-python
parentdev-python/spyder-kernels: drop dependency on dask (diff)
downloadgentoo-d8de8c649c8107cd54dd6edc08558fe9ec68b02a.tar.gz
gentoo-d8de8c649c8107cd54dd6edc08558fe9ec68b02a.tar.bz2
gentoo-d8de8c649c8107cd54dd6edc08558fe9ec68b02a.zip
dev-python/dask: drop 2022.12.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2022.12.0.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 1f923e08e0a7..53f60ef8fd72 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,2 +1 @@
-DIST dask-2022.12.0.gh.tar.gz 8226972 BLAKE2B 56def762c1899df9b355f54484b77cfde125e85287db488388130c92b388f014b7ddf8ccd4614918a5c6a15513c7fab207b4c2231105880a893af32e768ed675 SHA512 bc29f3735fb977a5b523d7ffbf55a99fd7a386388f1ebec3c44196d3b6870393163e023a2c64f1f8e7b8aae5342b9b0041a6628df72d14a0127513acf7f6c529
DIST dask-2022.12.1.gh.tar.gz 8233697 BLAKE2B 90caeb7a8a9abc03b035c787ae2f26d5dacbd8da9314b65deb7c38e1990a7d3067b4066c8f2bbb6d8179d03af471374df28e511f000097cb7b031e692e72ccd9 SHA512 1945f5737de55c559aff14c67efeee00afef18ff5dbdc07aa79affd89eb45a0808078bbc7ce24c904168e7c7a74a678a8dc90ed129593777dd25598cb45372b6
diff --git a/dev-python/dask/dask-2022.12.0.ebuild b/dev-python/dask/dask-2022.12.0.ebuild
deleted file mode 100644
index 3944d63ad468..000000000000
--- a/dev-python/dask/dask-2022.12.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
-HOMEPAGE="
- https://www.dask.org/
- https://github.com/dask/dask/
- https://pypi.org/project/dask/
-"
-SRC_URI="
- https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
- >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
- >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
- >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/toolz[${PYTHON_USEDEP}]
- test? (
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/numexpr[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # another test relying on -Werror
- "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
- # TODO
- dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
- dask/tests/test_config.py::test__get_paths
- dask/array/tests/test_linalg.py::test_solve_assume_a
- "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
- "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
-)
-
-python_test() {
- epytest -p no:flaky -m "not network"
-}