summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2017-12-25 19:24:14 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2017-12-26 02:04:48 +0000
commitda0bf376937f65083bf81f3ad8f1f01bde29ac04 (patch)
treeb9d35d567cf9513bd5300273ac658242d70292fa /dev-python
parentdev-python/botocore: simplify *DEPEND declaration (diff)
downloadgentoo-da0bf376937f65083bf81f3ad8f1f01bde29ac04.tar.gz
gentoo-da0bf376937f65083bf81f3ad8f1f01bde29ac04.tar.bz2
gentoo-da0bf376937f65083bf81f3ad8f1f01bde29ac04.zip
dev-python/boto3: add new 1.5.6 version
botocore version requirement updated per upstream info. Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.5.6.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index c08f3b9a6dcb..f536a9b0ca4e 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.4.4.tar.gz 194721 BLAKE2B f621e26dcb795218a37d8cd7a21a341740aec9ec6
DIST boto3-1.4.6.tar.gz 217110 BLAKE2B b666011953702f475696cbd4ca730326a5c75f9ec88777681c44f2e4df8d73b5afd6e9899c0aa0bacdb8a56325c9bc1107a66c7184dd6df8a4b91914d8f32558 SHA512 194be548af8b11fa14721a23934a811717c6e8a70178682c392626aaf97fd5738c7aeb83366d7951c2b69d63acc83f26059e3f0cb0b26f5d412ba606e02315e7
DIST boto3-1.4.7.tar.gz 217171 BLAKE2B 900c5c4249df9d0c3b5d157835f66be5e7cd3e2f4b934047340614ef729d30a5952f2996f1638626a10f9e5e55cb05d4792241b6f7da9c5157da9caeb464acac SHA512 db87ce873ba3d7d12c9e77ce329db3fab25328407ec5ba7fa1e7c94351285a84a3baf0f71721ee6858761743736497ec35b03e8d5e9a59da8daa176596f1a1a3
DIST boto3-1.4.8.tar.gz 217204 BLAKE2B d402c34608f86c8a337f39b816bf5202f3a231f8a15cb16da64fe2443d7ee9b3703eac7e57e4929cf07c4387f0eb4d029749e3d3368a23dfeb531da291b72e62 SHA512 91985508b02eb24e5770c51b17faca2e0cf194a1ca4cfc8313d296fee25001be729d9a5d5f9960bc3d756c6eefbb8694cbb931cb0109704401c4255f0486cb53
+DIST boto3-1.5.6.tar.gz 218891 BLAKE2B e2f9b567d8c4daad21895a6e8eff7e004229d96715e648c0f62705d5b3db1520e98e1b93d88650e8be98517e971258c0fae92ba09622f86081bb1a1665937645 SHA512 15eacfdf059634ad86a5c41b0ca237e24a6602b0cf9c897fc3d89b02dbebc93043c338d0e1d89d47bb619521943807829f67a384f450987ad5c85b34d1c76d81
diff --git a/dev-python/boto3/boto3-1.5.6.ebuild b/dev-python/boto3/boto3-1.5.6.ebuild
new file mode 100644
index 000000000000..e5e0c5c1a656
--- /dev/null
+++ b/dev-python/boto3/boto3-1.5.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/botocore-1.8.20[${PYTHON_USEDEP}]
+ <dev-python/botocore-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.1.10[${PYTHON_USEDEP}]
+ <dev-python/s3transfer-0.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.7[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ ~dev-python/mock-1.3.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}