summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-13 06:43:24 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-13 07:25:57 +0100
commitdbd61350440dda44d40cff00e7ecfa5daf4068d7 (patch)
tree176ac8dbd5ccf749f8f4daaececf3e6fd332cdd2 /dev-python
parentnet-dns/hash-slinger: added new version (diff)
downloadgentoo-dbd61350440dda44d40cff00e7ecfa5daf4068d7.tar.gz
gentoo-dbd61350440dda44d40cff00e7ecfa5daf4068d7.tar.bz2
gentoo-dbd61350440dda44d40cff00e7ecfa5daf4068d7.zip
dev-python/markdown: Bump to 3.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/markdown/Manifest1
-rw-r--r--dev-python/markdown/markdown-3.2.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/markdown/Manifest b/dev-python/markdown/Manifest
index a19c3dfc715f..0da09428a5be 100644
--- a/dev-python/markdown/Manifest
+++ b/dev-python/markdown/Manifest
@@ -2,4 +2,5 @@ DIST Markdown-2.6.11.tar.gz 274132 BLAKE2B 0d14d308c97d925db83d71f3b9be5622e77ee
DIST Markdown-2.6.8.tar.gz 307330 BLAKE2B 6867f15425bd84bc030ab52000dc2f83bff0c9885854cec4a2a785f80b18129160bc57da30226fe17f42043b4938482e2e4eff9cdb3d4370b0146cc09f1ff576 SHA512 85c1a16ebb50af79f378eb2fa936342df6174a4f597a74fee6d0495ef2bc4c7c8337463799e427cb6788b3429e400309958b5c4784f536593047ab2e47ac7c23
DIST Markdown-3.0.1.tar.gz 284084 BLAKE2B 6a9250295057ed32b389e1aeecf9aa3acac37ef48e6ca93a4821eb56a2323d65c1aed99799bf05811f27f45ba61f7bb704f69c6d2be706d8d2764c026e937905 SHA512 c648c1b8ecb3c907ff2bd636ec6c08b4b629967fb916913f77db641f6d61b83d16929af2f15f5695c8cdb9614031606110e02a7e0bbb3aab0be38a8e285f12f1
DIST Markdown-3.1.1.tar.gz 294136 BLAKE2B 9fd024f64f7aaa774a49f60e312e47bbc2ff0f368f083e4dfd0c38d1f12839dfcf3455f1d0c8cb0b9c851fe0d3a779c70784859f1682703bd6022d57b6548235 SHA512 78f089f2eef5c73d683ac96fd20c87145e243d12b0f230b9b0228b995035fbb084dde40be788679c63637f05956487ad520cc9dd61d133926bf13521aa600090
+DIST Markdown-3.2.1.tar.gz 297048 BLAKE2B b7f72cb856f0986e0e3920bd7d7eb65790312ef9f270ba3cfa679786b921d1c4ce0a86d591d7d748254c11e9c86d9883130efbc0c2d6a26d94b1fe3d9622aeb9 SHA512 5616c77004e4e8f2eb3b1276526ba131891be6edc7371b412a4050bbd59904220e48986d556bb9bb0b9e8acadfcde7828b609d165f68b6aad7bb90a221f80480
DIST Markdown-3.2.tar.gz 296747 BLAKE2B b2c5289330f8aca9d379878b522513adeeb9cc921cff39fe887beb40b8c7b96608fd56d7f95f201b41bbbc4cef759e40e164025f7f750183186bcf45553c609a SHA512 7f7c9a5a4846414aa8d4e9a9662ca49b08f393f7952bf2cffac493eb3e88406d3254466192b773ada0400013d669a9cea1b06e814af46f9667fdc8e20c079d65
diff --git a/dev-python/markdown/markdown-3.2.1.ebuild b/dev-python/markdown/markdown-3.2.1.ebuild
new file mode 100644
index 000000000000..77c56c8c71c0
--- /dev/null
+++ b/dev-python/markdown/markdown-3.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the markdown markup language"
+HOMEPAGE="
+ https://python-markdown.github.io/
+ https://pypi.org/project/Markdown/
+ https://github.com/Python-Markdown/markdown"
+SRC_URI="mirror://pypi/M/${PN^}/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc"
+
+BDEPEND="
+ test? (
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytidylib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && dodoc -r docs/
+
+ distutils-r1_python_install_all
+}