summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-19 04:09:31 -0400
committerTim Harder <radhermit@gentoo.org>2017-10-19 04:19:41 -0400
commitdcacd94deeb200f9e441847014e4ac861d71e612 (patch)
tree9c09d119bf12507e292ac56f4e91199087a27c10 /dev-python
parentdev-python/wheel: version bump to 0.30.0 (diff)
downloadgentoo-dcacd94deeb200f9e441847014e4ac861d71e612.tar.gz
gentoo-dcacd94deeb200f9e441847014e4ac861d71e612.tar.bz2
gentoo-dcacd94deeb200f9e441847014e4ac861d71e612.zip
dev-python/pyserial: version bump to 3.4
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyserial/Manifest1
-rw-r--r--dev-python/pyserial/pyserial-3.4.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pyserial/Manifest b/dev-python/pyserial/Manifest
index 584772e3d61f..22ca4b8868cf 100644
--- a/dev-python/pyserial/Manifest
+++ b/dev-python/pyserial/Manifest
@@ -1,3 +1,4 @@
DIST pyserial-2.7.tar.gz 122081 SHA256 3542ec0838793e61d6224e27ff05e8ce4ba5a5c5cc4ec5c6a3e8d49247985477 SHA512 3fc8d9425a47ebcd37db1fcc58182854b48c9abd6642f35fba2d21458d864ae448105d704dc0d880832ba7516fa16f108f24363bd5fa9f083ea79a4ac614339b WHIRLPOOL ae6b4df86220617f7fbc1f1e4085a7e85dca645a6d84339163b40fc7a15f14b879ef7a729d3d23d0300f9ee04b21d6c24d13a791d520aef3f3ad141c6acd9b68
DIST pyserial-3.2.1.tar.gz 147338 SHA256 1eecfe4022240f2eab5af8d414f0504e072ee68377ba63d3b6fe6e66c26f66d1 SHA512 8d3e580cc7781fc6549ab6e408642f4321eb90aafbe593f5dcf953001730f89ee32ce6592728764027a7944bfe4a0ebe2cfac1fce071777aac7c4f27ac94ab7f WHIRLPOOL 529c4eb12adf88579d528d3bd9dfec6fd7b43890217392677b7c8428f7ca7b3fe5dded863c4690c9eaa5ea37a2cdb56744e328a47a4b89d5440becceb983ecb8
DIST pyserial-3.3.tar.gz 149032 SHA256 2949cddffc2b05683065a3cd2345114b1a49b08df8cb843d69ba99dc3e19edc2 SHA512 57a0bcd0684530e1d60022804dd75acd5d9a9a358c92d967076884b2419bcfefae71e949f7aba1737023f6b089c993e98dd7cf6860e9402ed7e0b698953b3ac8 WHIRLPOOL 41174cb26532f563950aa1510d5fe2ab60def9141744ffad5d063f2a0e9cd7e0fdaf68db6c72ec47b2eb8fd37aa064286c27a90288ae1482e1f336574e9a1b1a
+DIST pyserial-3.4.tar.gz 151657 SHA256 6e2d401fdee0eab996cf734e67773a0143b932772ca8b42451440cfed942c627 SHA512 d71dffc330704e41caac6054adf192bee2f1c119691faf2ea93fe22e8e3ba000dc4a1434293f6f80d05a5577d85b96791f656e28d5c63fb0ce6a6605467a117f WHIRLPOOL ec79c65dfd5469dffc9f8be2a19742e3c2de591a8ff00f2350a57f3d3b948176b88b232aafb24b79d33a762b6fd7687e80c8e0915d6a01c05e5c990456f5c734
diff --git a/dev-python/pyserial/pyserial-3.4.ebuild b/dev-python/pyserial/pyserial-3.4.ebuild
new file mode 100644
index 000000000000..49af25222514
--- /dev/null
+++ b/dev-python/pyserial/pyserial-3.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Serial Port extension"
+HOMEPAGE="https://github.com/pyserial/pyserial https://pypi.python.org/pypi/pyserial"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc examples"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+# Usual avoid d'loading un-needed objects.inv file
+PATCHES=( "${FILESDIR}"/mapping.patch )
+
+DOCS=( CHANGES.rst README.rst )
+
+python_compile_all() {
+ use doc && emake -C documentation html
+}
+
+python_test() {
+ ${EPYTHON} test/run_all_tests.py || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/_build/html/. )
+ distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}