summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-18 22:44:01 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-18 23:44:21 +0100
commitdcc1abb5c0f274dd860d2913160962b1d069321f (patch)
treedd4572bfec37fd44ed69dcb0a1c166d7a3047d9b /dev-python
parentnet-misc/owncloud-client: 2.10.0.6519 bump (diff)
downloadgentoo-dcc1abb5c0f274dd860d2913160962b1d069321f.tar.gz
gentoo-dcc1abb5c0f274dd860d2913160962b1d069321f.tar.bz2
gentoo-dcc1abb5c0f274dd860d2913160962b1d069321f.zip
dev-python/botocore: Bump to 1.23.38
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.23.38.ebuild65
-rw-r--r--dev-python/botocore/botocore-9999.ebuild6
3 files changed, 69 insertions, 3 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 9ceee2f2c5c3..82af4a47595a 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -10,4 +10,5 @@ DIST botocore-1.23.33.tar.gz 8712535 BLAKE2B 97064bfe24db14e49ff37b515549a2294ed
DIST botocore-1.23.34.tar.gz 8718420 BLAKE2B 67325949a37c3a3ff61e66279626c30b8f225d74137512d9a45414e1af11a18dd5fba5f0f4e64dd71c3d0bbbabf210d6e8a63901bc6deba8f16e3cfc163ebb81 SHA512 8afdf0a186f4850e8905ef1cd6660ab8ea58546cc119a47085976adc51195c0b9d524c077a3dcef6687cc5977988532932a424023dfea83eb7efd1e19b19eb95
DIST botocore-1.23.35.tar.gz 8719275 BLAKE2B 2bda51eef1ac3d420952751d610722fbb57e004e8503e17dddd0a31e7ab360ba719c97f97d4b9e5aa6440965bafea9966b11d246e85fe753633c88141881cbfa SHA512 84a8692d840d9c8930ad8f80756f4d6ce6350e6a655966ff33ffd7f2bf5f5997989d6cc9067b52dd5631f49c35b5120eaa3d533274f322581281810ab47b988a
DIST botocore-1.23.37.tar.gz 8728451 BLAKE2B 039352d4c727433cc5aef435cd7527fa3bc6027c3db8b2a27219d4cab8f602f74995b09e5407c1df1c7a51e37830db7e8f351484485f6b822499933c35607472 SHA512 79004d38fbfc744d2fd91364a1cc99d8be1f2d03f25f2ba77df0da4b4d429a156ac5d52ca523ee4992ff99ac83b7a14e7f49e3b12b9b6f91e164fb720c41e10d
+DIST botocore-1.23.38.tar.gz 8732008 BLAKE2B 012dbd44294038234ca127b5c2db924ecf4a6c17d91a4a5e8f1e58b860dba605cc43248035f8bc0b485e993c65ec5b6ba2d54ae4b9d93d423afedc025f806a40 SHA512 22c04b7d18c2642ea45e11886fac6379fea14466d7f03fc976c4a81e42166583d1702888229ba560d4220781e742ff0264bae5df94e2d00b945259efc35f6016
DIST botocore-1.23.5.tar.gz 8374467 BLAKE2B 467092e7d8aa5ccb756132669049865445a47205913964c1c944b20caaf100b1efdd1bf3af9c5416ff079b487e6d4d08ffe6208e2b352d09655cc5be21c88739 SHA512 6afca19b724f9019f21e5993ce970d605b95d31c1a4e969ec1b4080510a5a120b3fa0cfd5ade973a9203bd6b7983a3dbca2f7a03108a9167392efd60d5e2fe9b
diff --git a/dev-python/botocore/botocore-1.23.38.ebuild b/dev-python/botocore/botocore-1.23.38.ebuild
new file mode 100644
index 000000000000..79a1cd5da0e2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.23.38.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit}
+}
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index 80a198d56414..79a1cd5da0e2 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -16,7 +17,7 @@ if [[ "${PV}" == "9999" ]]; then
inherit git-r3
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
RDEPEND="
@@ -60,6 +61,5 @@ python_test() {
tests/functional/test_six_threading.py::test_six_thread_safety
)
- distutils_install_for_testing --via-venv
epytest tests/{functional,unit}
}