summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-03-11 16:06:06 -0400
committerRick Farina <zerochaos@gentoo.org>2019-03-11 16:12:28 -0400
commitdce536bbc1d9f7e5851abdc26abe9260a4adcde0 (patch)
treed2f3a69c71854b34e120665b8749af07a44068be /dev-python
parentsys-apps/sysvinit: stable 2.93 for sparc, bug #679818 (diff)
downloadgentoo-dce536bbc1d9f7e5851abdc26abe9260a4adcde0.tar.gz
gentoo-dce536bbc1d9f7e5851abdc26abe9260a4adcde0.tar.bz2
gentoo-dce536bbc1d9f7e5851abdc26abe9260a4adcde0.zip
dev-python/simplekml: initial commit
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/simplekml/Manifest1
-rw-r--r--dev-python/simplekml/metadata.xml16
-rw-r--r--dev-python/simplekml/simplekml-1.3.1.ebuild21
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/simplekml/Manifest b/dev-python/simplekml/Manifest
new file mode 100644
index 000000000000..e726ea5a9876
--- /dev/null
+++ b/dev-python/simplekml/Manifest
@@ -0,0 +1 @@
+DIST simplekml-1.3.1.tar.gz 37070 BLAKE2B 33d4c9bb7d77f80dd65901dc1f1f0d1f1586b6a800ac63a011b398d8bc13591b50e21d3e0ba36ff6f3b728ccf355fb021225a63846f4784b2b52d59526045154 SHA512 a72d378b44ccbe5f597f100784f3e802255c9a47216132f6ad13e594a2fb70058224428df5b7450ad7e498b9cfbfd846191d30dae225169957ea35659dd0968a
diff --git a/dev-python/simplekml/metadata.xml b/dev-python/simplekml/metadata.xml
new file mode 100644
index 000000000000..efb80665c0e3
--- /dev/null
+++ b/dev-python/simplekml/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">simplekml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/simplekml/simplekml-1.3.1.ebuild b/dev-python/simplekml/simplekml-1.3.1.ebuild
new file mode 100644
index 000000000000..a082887aa256
--- /dev/null
+++ b/dev-python/simplekml/simplekml-1.3.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="enables you to generate KML with as little effort as possible"
+HOMEPAGE="https://pypi.org/project/simplekml/"
+#SRC_URI="https://files.pythonhosted.org/packages/62/88/feeb5ac5ae528c81daed9fe9864ec42496b80ffbcf83ac60bb6feb5b7f80/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""