summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-06-07 00:24:11 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-06-07 00:24:45 -0500
commitdd071c2b8cd2b4a0799d56c1a581a1a20517de5c (patch)
treebb3334b5243c9c3fe5d8884d1fcb77a6fe6c95af /dev-python
parentdev-python/oslo-utils: 3.35.1 bup (diff)
downloadgentoo-dd071c2b8cd2b4a0799d56c1a581a1a20517de5c.tar.gz
gentoo-dd071c2b8cd2b4a0799d56c1a581a1a20517de5c.tar.bz2
gentoo-dd071c2b8cd2b4a0799d56c1a581a1a20517de5c.zip
dev-python/pbr: 4.0.4 bup
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pbr/Manifest1
-rw-r--r--dev-python/pbr/pbr-4.0.4.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index 9c7fe01aa9cc..cc4303542587 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -3,3 +3,4 @@ DIST pbr-1.10.0.tar.gz 111425 BLAKE2B 2cef589ada2892dd8357ad3248c4b544d58c699d24
DIST pbr-3.1.1.tar.gz 102665 BLAKE2B 301515d50f8550f5553a29faacb1daef589b41b8116320abd4552bb67886498d89eced1f95e1efdd6ac0511a5587eb479dc9d2963a74e92300463c3c53201e7d SHA512 c01fb83678f8fc3acddc153dd341a17ed9d602b6770f0ff244b1c5b54c37d4ddcbd0c3d726f7d7020865819e02797c1c79a0c15e9ee2ae5c1510fce7112b2a3a
DIST pbr-4.0.2.tar.gz 107720 BLAKE2B 346e74414cb77da61be08eee39148991aff7eaea7bab54407ce9dc48f422c576fd2125c11acb31cdf54cecb059281cf540c4ccfa005056c5c3b276ea2161c873 SHA512 d678c933a1d1b0319358b0d067291d29467582e6abb26e21386b9d98092f561e3b76965e0b18e12e88abab790b737606ae2a37cc11cb0a4a34ff6c1ad99cfdb1
DIST pbr-4.0.3.tar.gz 108684 BLAKE2B e3a9a695b04333a9523c8e749628773cd12f38e87cd6cc670b8ba40b800871004a5cd9d038913e5f483291d180afbeb524535c6c68833ee48adde6ff276783f4 SHA512 9e5c915bd661e3356ad1b92b3d01df3a592a6120c9dc58d3e4bfbc3040f2d69f896244ea8f6c9cffad3e774747d330cd03e928cfc160e5df980c134fe2dee801
+DIST pbr-4.0.4.tar.gz 109077 BLAKE2B efe901b074cd6747fe123b6a325cb45e010d774834a875e86647b6a9c3afbaff9e435087e757ae4276c0b18558faeea57c8dec6b2039ab7b0f70424f64d94f57 SHA512 fc849a27c3b5deb89545dd05eb102a14f2c42a0d617f474df46b3292c14ab7e0a4343cd6e1a38eef77815cca49374d58698cb0c2fdd2aa5f2f47e890939adbb3
diff --git a/dev-python/pbr/pbr-4.0.4.ebuild b/dev-python/pbr/pbr-4.0.4.ebuild
new file mode 100644
index 000000000000..3d26767fc84d
--- /dev/null
+++ b/dev-python/pbr/pbr-4.0.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
+# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-14.0.6[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+PDEPEND=""
+
+# This normally actually belongs here.
+python_prepare_all() {
+ # This test passes when run within the source and doesn't represent a failure, but rather
+ # a gentoo sandbox constraint
+ # Rm tests that rely upon the package being already installed and fail
+ sed -e s':test_console_script_develop:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -e s':test_sdist_extra_files:_&:' \
+ -e s':test_command_hooks:_&:' \
+ -e s':test_sdist_git_extra_files:_&:' \
+ -i pbr/tests/test_core.py || die
+ sed -e s':test_command_hooks:_&:' \
+ -e s':test_global_setup_hooks:_&:' \
+ -i pbr/tests/test_hooks.py || die
+ rm pbr/tests/test_wsgi.py || die "couldn't remove wsgi network tests"
+ einfo "rogue tests disabled"
+ sed -i '/^hacking/d' test-requirements.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}