summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-30 13:02:07 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-30 13:12:02 +0100
commitdd2b34c94e6b979b65da9ab52f7ad23bd0341e19 (patch)
tree994b316da9b1e2755607b79eef240c089d1437d2 /dev-python
parentdev-libs/libnl: Add live ebuild for SLOT=1.1 (diff)
downloadgentoo-dd2b34c94e6b979b65da9ab52f7ad23bd0341e19.tar.gz
gentoo-dd2b34c94e6b979b65da9ab52f7ad23bd0341e19.tar.bz2
gentoo-dd2b34c94e6b979b65da9ab52f7ad23bd0341e19.zip
dev-python/pypy: Use updated dev-lang/python patchset
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypy/Manifest2
-rw-r--r--dev-python/pypy/pypy-7.3.0.ebuild8
2 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/pypy/Manifest b/dev-python/pypy/Manifest
index 4facc6d43164..1f70ebaafe4f 100644
--- a/dev-python/pypy/Manifest
+++ b/dev-python/pypy/Manifest
@@ -1,2 +1,2 @@
DIST pypy2.7-v7.3.0-src.tar.bz2 20328540 BLAKE2B 7f71c98f436f11e8f4d248b6aeb3e2f81962cdeeaf3eb534473f1c6b5e8cd37d9abc047d7fa750a1ceeeaa63fab6eff6e5f1e60394b8104bbcd7e1fc47885c61 SHA512 05f039f090d837a72012db55f23d94da3f21c7458f18bd1e8ba632489248eb6486ced07b786d05e573abf2b3def2a68d96e7e1109e6d189d8e6c303c60ee3535
-DIST python-gentoo-patches-2.7.17.tar.xz 13476 BLAKE2B 788688e2941d2d6d4f768168881b2c3639213a97e214557b3a93f8db44d81e2b6d70be847b7462e54e3786660ebee4ee331402081d92167d74ad149279c3f389 SHA512 1641737635d33607a77ed2ee2462854cec603be39737de3f81abb188702aaf46f039d1616f9dcd413da1f4a8040175c66a2883e496132c2e4ebe8f860b36f9f1
+DIST python-gentoo-patches-2.7.17-r1.tar.xz 14708 BLAKE2B f6e25236a471649de122d0f29506f7a4f34044a568ead47a68980411d9722b761fe1f9d653d5edccb6978b65c8c1eecbef55f403b94f32b37c0ad68e061505a8 SHA512 ecdde5e38c6fe5e69691fb3a68c8f4f43da7857d4abaff763d3cf6ad864ba43c769c03b186b60f2736a1ffb1e3e4c9982715d1b8a99ff3f5740096153bb8a90f
diff --git a/dev-python/pypy/pypy-7.3.0.ebuild b/dev-python/pypy/pypy-7.3.0.ebuild
index 74783b2585cb..06f51df2fc88 100644
--- a/dev-python/pypy/pypy-7.3.0.ebuild
+++ b/dev-python/pypy/pypy-7.3.0.ebuild
@@ -5,14 +5,14 @@ EAPI=7
inherit pax-utils python-utils-r1
-# note: remember to update this to newest dev-lang/python:2.7 on bump
-CPY_PATCHSET_VERSION="2.7.17"
MY_P=pypy2.7-v${PV/_/}
+# note: remember to update this to newest dev-lang/python:2.7 on bump
+PATCHSET="python-gentoo-patches-2.7.17-r1"
DESCRIPTION="A fast, compliant alternative implementation of the Python language"
HOMEPAGE="https://pypy.org/"
SRC_URI="https://bitbucket.org/pypy/pypy/downloads/${MY_P}-src.tar.bz2
- https://dev.gentoo.org/~mgorny/dist/python-gentoo-patches-${CPY_PATCHSET_VERSION}.tar.xz"
+ https://dev.gentoo.org/~mgorny/dist/python/${PATCHSET}.tar.xz"
S="${WORKDIR}/${MY_P}-src"
LICENSE="MIT"
@@ -49,7 +49,7 @@ src_prepare() {
# TODO: cpy turkish locale patch now fixes C code
# probably needs better port to pypy, if it is broken there
eapply "${FILESDIR}"/5.8.0_all_distutils_cxx.patch
- eapply -p2 "${WORKDIR}"/patches/0010-use_pyxml.patch
+ eapply -p2 "${WORKDIR}/${PATCHSET}"/0010-use_pyxml.patch
popd > /dev/null || die
eapply_user