summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-19 13:34:00 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-19 13:34:00 +0200
commitddc3f810065c306e24fe559791805a13f27f5ed2 (patch)
tree674b9123b5bfb9ae251729a179f472849b7eeabe /dev-python
parentsys-libs/libomp: Bump to 7.1.0 (diff)
downloadgentoo-ddc3f810065c306e24fe559791805a13f27f5ed2.tar.gz
gentoo-ddc3f810065c306e24fe559791805a13f27f5ed2.tar.bz2
gentoo-ddc3f810065c306e24fe559791805a13f27f5ed2.zip
dev-python/pygit2: Bump to 0.28.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygit2/Manifest1
-rw-r--r--dev-python/pygit2/pygit2-0.28.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index 001dd663155b..d78ddd69f4c8 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1,2 +1,3 @@
DIST pygit2-0.26.4.tar.gz 477318 BLAKE2B d17ef799ff3eab3629194fe0fe90dcc335e40509c13f53bc8f8e0b01e93dc838ca474a5e4ef44c9be2eac7d08e98c735820e936cbbcb7f398f76f9732954bc69 SHA512 e459e47bfa8137421625633a731d49882d95a52d4f2d672f2c8efe7cd6cca4b33335ee77777a353b309df4917d9b29b30c1f9a96b7e226e3e7fe0cd34bbefce6
DIST pygit2-0.27.4.tar.gz 479157 BLAKE2B 5b650c7916127219ba18212f035793bb805adda570dd4a89cc7fcda8af581c7aa3916d2851117a5efe7b434dbe2e9ff103e37e69de5d158d0a58162b15f1e18b SHA512 046e8830d403d869418a8cf7f22549293e336fa1b8fc108489c3c2299316838724d1eebc8747005d594e1c6c3596aafa5192dd64a1f34e0a2d080c83214324da
+DIST pygit2-0.28.1.tar.gz 496243 BLAKE2B cfd9ddc8b1e5665016a2743bb0a2f6f5821e08a5173f7be4d99b11e1bf5bc0ba97a9d9fce7eb560f6394f30f23f7b7ce69abc5968ac2d566565c6b06b06f0f8f SHA512 46bb9d6150b7413311f26ea1aeae15cdcd22a2d5c4cafa17bd8a1c02dbf0c9a630cf89583e77a07be5c74334ac28a672de31290ba986476ded25e8a19abf7f3b
diff --git a/dev-python/pygit2/pygit2-0.28.1.ebuild b/dev-python/pygit2/pygit2-0.28.1.ebuild
new file mode 100644
index 000000000000..020409cd616d
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.28.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 eapi7-ver
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ =dev-libs/libgit2-$(ver_cut 1-2)*
+ >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -vv --import-mode=append test || die
+}