summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2019-08-16 07:21:25 +0200
committerSlawomir Lis <slis@gentoo.org>2019-08-16 07:21:38 +0200
commitdfbdeb188385a2e8aeb5d9b1526ed6c63ea637ad (patch)
treee3de5653f37c2766c71546a07aa5b0bb413878bd /dev-python
parentdev-python/URLObject: version bump to 2.4.3 (diff)
downloadgentoo-dfbdeb188385a2e8aeb5d9b1526ed6c63ea637ad.tar.gz
gentoo-dfbdeb188385a2e8aeb5d9b1526ed6c63ea637ad.tar.bz2
gentoo-dfbdeb188385a2e8aeb5d9b1526ed6c63ea637ad.zip
dev-python/URLObject: Removed boundled six
Closes: https://bugs.gentoo.org/616082 Package-Manager: Portage-2.3.71, Repoman-2.3.16 Signed-off-by: Slawek Lis <slis@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/URLObject/URLObject-2.4.3.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/URLObject/URLObject-2.4.3.ebuild b/dev-python/URLObject/URLObject-2.4.3.ebuild
index b628b00bb781..52b54f19514b 100644
--- a/dev-python/URLObject/URLObject-2.4.3.ebuild
+++ b/dev-python/URLObject/URLObject-2.4.3.ebuild
@@ -19,7 +19,8 @@ KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="test"
-RDEPEND=""
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]"
DEPEND="
${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
@@ -28,6 +29,13 @@ DEPEND="
S=${WORKDIR}/${GITHUB_P}
+python_prepare_all() {
+ rm "${S}/urlobject/six.py" || die
+ find "${S}/urlobject" -type f -name \*.py \
+ -exec sed -e 's/from \.six import/from six import/g' -i "{}" \; || die
+ distutils-r1_python_prepare_all
+}
+
python_test() {
nosetests -v || die "Tests fail with ${EPYTHON}"
}